Author Topic: [APP] - version 2.17.X+ (updated 28.12.2013)  (Read 64285 times)

Offline joeloc

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 331
    • View Profile
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #165 on: November 18, 2013, 20:36:44 »
any new problem? :)

No... but mountains would be good for you. And also good for Locus altitude features in general, which currently suffer from their creator living in a flat-as-a-pancake place. :)
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11793
  • Thanked: 417 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #166 on: November 19, 2013, 13:24:00 »
Quote
how is it possible that you see smiley as icon and also star for "computed"?
you misunderstood, i wrote
Quote
when i mark it as "computed" the icon get a crown and no red star.
The smiley get a crown after i marked it as computed.



ah I see it now. Hmm as I wrote in any post before, system for drawing a geocache icons is little bit weird and complicated now. It needs to be rewrote, but because it's little bit risky, I'll leave it to next bigger version, when will be enough time to test all possibilities.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline john_percy

  • Master of Locus
  • ****
  • Posts: 807
  • Thanked: 121 times
    • View Profile
  • Device: MotoG
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #167 on: November 20, 2013, 10:17:49 »
Car Parking nodes no longer appear with internal themes
In http://forum.locusmap.eu/index.php?topic=3423.msg24409#msg24409 I commented that the standard Osmarender includes rules that say there must be either no access key, or access must be yes or public for the parking icon to show and Voldapet changed the internal themes accordingly.
However parking nodes no longer appear in the Locus internal themes (though areas/ways do). It appears that the test for no "access" key in the following code does not work for nodes, though the equivalent code does work for ways.
Code: [Select]
<rule e="node" k="amenity" v="parking">
<rule e="node" k="access" v="~">
<symbol src="file:/symbols/parking.png" />
</rule>
<rule e="node" k="access" v="yes|public">
<symbol src="file:/symbols/parking.png" />
</rule>
</rule>
I don't know if this is a bug in the Locus code or implicit in the data but in fact the dummy code from OpenStreetMap at https://trac.openstreetmap.org/changeset/6939/subversion does not test for access permissions in parking nodes.
 

Offline jurek77

  • More than Newbie
  • *
  • Posts: 11
    • View Profile
  • Device: Motorola XT320 Defy mini, Nexus 7 2013
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #168 on: November 21, 2013, 01:01:05 »
Hello Menion.
In Android 4.4 (KitKat) on Nexus 7 2013 (version 2.17.3),  menu settings (Display to Miscellaneous) is not working. White screen.
In version 2.17.1.3 menu settings is working ok, on Android 4.4.
« Last Edit: November 21, 2013, 09:42:28 by jurek77 »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11793
  • Thanked: 417 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #169 on: November 21, 2013, 16:22:51 »
@percy: I'll forward this issue to peter

@jurek: I know, sorry. Interesting issue, caused by one change in Android system. "Funny" on this is fact, that I was fixing it right before release, tested it, but it's still in public version. Probably some part of precompiled code remained in memory during creating a version. We now discuss, if release another version (2.17.x is really cursed) immediately or wait at least a week ...
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Online balloni55

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 2676
  • Thanked: 125 times
    • View Profile
  • Device: Samsung XCover 4s Android 10
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #170 on: November 22, 2013, 10:08:27 »
Hello  menion
the behavior discribed in replay#113 and #116 always exist.
kml export to dropbox is only possible when you select "sdcard" and "send data", so you export it twice :-[
Direct export to dropbox is always kmz
« Last Edit: November 22, 2013, 13:54:54 by balloni55 »
Locus PRO 3.47.2
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11793
  • Thanked: 417 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #171 on: November 22, 2013, 10:13:21 »
balloni, I already few times wrote that this is not a bug, but an intent. For example here http://forum.locusmap.eu/index.php?topic=3488.msg24751#msg24751 . I'm sure this is not a big problem
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Online balloni55

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 2676
  • Thanked: 125 times
    • View Profile
  • Device: Samsung XCover 4s Android 10
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #172 on: November 22, 2013, 14:00:18 »
Sorry menion, i didnt noticed :-[, you are right it is not a  big problem
Locus PRO 3.47.2
 

Offline Bob Denny

  • More than Newbie
  • *
  • Posts: 80
    • View Profile
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #173 on: November 23, 2013, 15:32:15 »
@menion -- on #168 (blank settings pages), I noticed that while displaying the satellites, from that menu if you open GPS and Location settings, they show fine! But doing it from the main "gear" Settings icon, all settings pages are blank. It is strange.
 

Offline joeloc

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 331
    • View Profile
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #174 on: November 26, 2013, 09:40:43 »
I am playing with WMS for the first time and it seems kind of unusable at the moment. Using any of the maps from
http://www.igac.gov.co/wps/portal/igac/raiz/iniciohome/MapasdeColombia/Descargas
eg
http://geocarto.igac.gov.co/geoservicios/cien_mil/wms
makes Locus crawl like a snail and almost always busyloop one core (galaxy note 2). Is this to be expected with WMS? I thought it was basically just tile downloading, so the performance should be more or less equal to other online maps, but maybe I am mistaken.

I also just had Locus crash after playing with those maps for a few minutes.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11793
  • Thanked: 417 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #175 on: November 26, 2013, 09:56:04 »
@bob: weird, but it make sense for me. Version will be out during a weekend, sorry for troubles

@joeloc: no no, wms maps are in 90% much slower then normal online maps. Tiles are not stored on WMS servers, but are generated on-the-fly based on Locus requests. They are also not cached, so every tile is requested again when needed
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline joeloc

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 331
    • View Profile
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #176 on: November 26, 2013, 22:13:55 »
@joeloc: no no, wms maps are in 90% much slower then normal online maps. Tiles are not stored on WMS servers, but are generated on-the-fly based on Locus requests. They are also not cached, so every tile is requested again when needed

Ok, but that doesnt explain Locus eating all CPU and busylooping a core and scroll with 1 fps while WMS overlays are active. I think I even had it busyloop when I was inside the map manager on the WMS tab.
 
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11793
  • Thanked: 417 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #177 on: November 27, 2013, 10:39:29 »
ah got it, nice. Problem is simple. Every WMS server return XML file with it's information, paremeters etc. Locus keep this definition and read it every time, you need to work with WMS layer. Usually, these XML files are around 10 - 30kb big, so parsing took less then second. Unfortunately I discovered that XML file from server you mention, has more then 200kb! and even on Nexus7, it took almost 5 seconds to parse it.

It's not too important problem now, but I'm placing it to my TODO list to any of next versions, because it definitely needs to be fixed. Thanks
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline joeloc

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 331
    • View Profile
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #178 on: November 27, 2013, 22:12:59 »
It's not too important problem now, but I'm placing it to my TODO list to any of next versions, because it definitely needs to be fixed. Thanks
Looking forward to Locus 2.18.1 :-)
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11793
  • Thanked: 417 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.17.X+ (updated 15.11.2013)
« Reply #179 on: November 28, 2013, 12:13:38 »
we are just uploading new version on Google Play. I wanted to have a month without any version, but problem on A4.4 with settings, forced me to update. So there is a few minor changes and also a public version of "Generator of navigation" for plain tracks. Texts in this feature are not available for translation, because I hope you suggest me better once :)

Hope all main features will works on 100%, less importat in worst case on 99%

enjoy Locus and a coming weekend
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!