[APP] - version 2.17.X+ (updated 28.12.2013)

Started by Menion, October 30, 2013, 13:56:32

0 Members and 1 Guest are viewing this topic.

Henk van der Spek

@rvheddig: Tap on the text where the arrow is pointing and the "beep" settings menu will open.

Motorola G52 5G 6/128 Android 12 and Motorola Moto G5g Plus 6/128 Android 11
  •  

gynta


Menion

thanks gynta, I completely missed that. Added second line for these long texts, thank you!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

rvheddeg

@Henk: I know :-). I think I was not making myself very clear. What I meant was that the explanation in Dutch in the Quick Switch menu is wrong/confusing. That's all
  •  

balloni55

 8) 8) 8) i have to speed up to 290Km/h :P :P :P


"Time to target" display the same time as "Time to next junktion" ;)
Locus Map Classic 3.65.2 AFA
Locus Map 4.14.2.1 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

jurek77

Hello Menion !
Thanks for new version.
In version 2.17.1.3 IVONA is working ok, but
in version 2.17.2 IVONA is not working (polish voice) on Nexus 7 v2 (android 4.3).
On Motorola XT320, IVONA is working ok (version 2.17.2).
  •  

Menion

#141
you're welcome

Since around 2.16.0, I do not change anything around inializing of TTS voices. So if in testing versions it works for you and in published not, then you have definitely something incorrectly set. Best is to try to set it again in TTS manager (menu > settings > localization)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

jurek77

It is ok, thank  you.
IVONA is working ok.
  •  

joeloc

#143
The selection counter in the track list is broken. Right now, it says 18/58 for a folder, yet only two tracks are actually selected when I go into that folder. I dont know how it happened, but thats the current state. I am sure I had those 18 tracks selected before and Locus somehow lost their selection state.

Same happens for other folders (eg saying 15/35 but only one is actually checked). When I enable another track, the selection counter stays at 15/35. This is with last beta from this thread, not with market version.

  •  

CaptKaos2

Having not used Locus for a while (Due to work commitments and illness) I wanted to get rid of a TB I've had for too long. I had updated Locus last night to 2.17.2.  When I arrived at the cache site and tried to log the find. On pressing the Field note button the screen hung for 10-15 seconds then I got a window stating "Unfortunately, Locus Pro has stopped", and on pressing OK the app started again. 
As I am one of the many Samsung Galaxy S3 users who had installed the 4.3 update before Samsung pulled it due to the numerous errors. I installed Locus Pro 2.17.2 onto my Nexus 7 when I got home, but I am still getting the same error on it.
  •  

stebu

#145
Hi Menion!
(edit)
OK, so I didn't notice the crowns. They are shown on the map only. I hope the list view gets it, too.

I cannot get the red star for customcoords, not in list nor on map :(
There is an exception, though, a cache with a strange name shows the icon with a red star:
{name}GC40NZN{/name}{desc}"!*!8n3n 53#"58%83"58 UcbR40NZN=?:F=0{/desc}
{sym}Geocache{/sym}{type}Geocache|Unknown Cache{/type}
{groundspeak:cache id="GC40NZN" available="True" archived="False" memberonly="False" customcoords="True" xmlns:groundspeak="http://www.groundspeak.com/cache/1/0/2"}
{groundspeak:name}"!*!8n3n 53#"58% UdbR40NZN{/groundspeak:name}

Favorite points are shown incorrectly? If I include {groundspeak:favorite_points}46{/groundspeak:favorite_points}
There is a small blue icon in the list, but the number is always zero (0). When you fix this, it should also be shown in the basic info of the listing.

(/edit)
I tried to get the new cache features to work. No success!?
Have you implemented memberonly="True" and customcoords="True" features in 2.17.2 (pro)?

Only in one cache did I get the customcoords indication, I don't know what is different in it?

Also, the cachetype does not work:
{groundspeak:cachetype id="8"}Unknown (Mystery) Caches{/groundspeak:cachetype}
Container seems to work:
{groundspeak:container id="2"}Micro{/groundspeak:container}
I have changed {gpx xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" version="1.0" creator="Groundspeak, Inc. All Rights Reserved. http://www.groundspeak.com" xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd http://www.groundspeak.com/cache/1/0/2 http://www.groundspeak.com/cache/1/0/2/cache.xsd" xmlns="http://www.topografix.com/GPX/1/0"}
  •  

Menion

#146
@joeloc: sorry, but as usually, I'm unable to reproduce this problem. A way to simulate this problem is welcome

@CaptKaos2: damn ... I see it. Seems this happen to users, that never logged a cache before with current version of Locus. So not to current users, but only to new one (or users that do not used this feature for a long time). Seems to be another quite serious problem where only help is to restore settings (in attachment - that unfortunately overwrite all your settings you have in app). Sorry for this, I'll have to release one more version soon, uff ...

@stebu: it will be longer ...

1) crowns in list of caches - agree. Unfortunately I have little bit "complicated" system for creating cache icons and it's simplified version is just in list of caches. So for now, it's not simply possible.

2) red star - is visible in case, you modify original coordinates of cache or you import a cache together with final waypoint, or you check in cache screen "Computed" checkbox

3) favorite points - I'm not sure if groundspeak:favorite_points is even officially supported by google anyway I found an issue during import that always set amount to '0', so fixed now

4) "Have you implemented memberonly="True" and customcoords="True" features in 2.17.2 (pro)?" - "memberonly" yes, new imported caches that has set this to true, should be on map visible with small crown. "customcoords" no, I do not know this parameter

5) cache type "Unknown (Mystery) Caches" - I do not know this definition. Where this comes from? Also in your XML sample you write about GPX Groundspeak extension version 1.0.2, but this do not officially exists as I know
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

stebu

Hi Menion!

GS GPX schema 1/0/2 was introduced in Balloni's post, which you acknowledged :)
http://forum.locusmap.eu/index.php?topic=3488.msg25219#msg25219
  •  

Menion

hmm, I miss that it's already 1.0.2. So even "memberonly" is from this new schema? Is it already official or it's just some "beta"?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

CaptKaos2

Thanks menion.
I overwrote the files in my Locus folder with those in the zip file, rebooted my phone and tried again. The problem is still there.
It's not a big problem for me at the moment, as I don't think I will be out on the moors for at least another week or two. I'll wait for the next version.
  •