thousands of red lines to waypoints of Geocaches

Started by mike, May 17, 2013, 18:25:14

0 Members and 1 Guest are viewing this topic.

mike

Hi,
since today I have thousands of red lines on my map, that I would like to get rid of - dont show them.
they connect each Geocache symbol with its waypoints.
I also do not want to see all waypoints of all caches at the same time. I just liked to see them, when I active one Geocache.

Please telme how I could hide them (line and waypoints) and only show waypoints of the active cache.

I attach ascreener that shows my desaster ...

Thanks a lot,

Mike

 [attachment=0:34wxnm8f]20130517_180954.jpg[/attachment:34wxnm8f]
  •  

balloni55

#1
Update locus, these red lines was a bug in a further version
Locus Map 4.23.1 Gold AFA

LM4 User ID e06d572d4
  •  

mike

#2
Quote from: "balloni55"Update locus, these red lines was a bug in a further version

I always use the newest Locus version
to time: Locus PRO 2.11.1

on SGS2 Android 4.1.2 IceCreamSandwich
  •  

Menion

#3
I think it's not just a problem of Locus. Seems you really have loaded all waypoints to all visible caches.

Question is how you do it. There are two possibilities
1. menu > more (functions) > geocaching tools > Load all waypoints - this load all waypoints for visible caches. This is anyway just one time actions so next time you hide/show caches, they'll not have loaded waypoints. Way to remove it is for example in menu > data > tab items and top button "hide" in action bar

2. menu > settings > geocaching > automatic waypoint loading. This will load waypoints to cache everytime you display any cache. It's maybe your case. So uncheck this settings and hide existing waypoints as described in choose 1, or just hide/show caches

hope this helps you
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

kristianmatthews

#4
Quote from: "mike"
Quote from: "balloni55"Update locus, these red lines was a bug in a further version

I always use the newest Locus version
to time: Locus PRO 2.11.1

on SGS2 Android 4.1.2 IceCreamSandwich

I have the same thing now. It goes away if I clear all the map items, but it only appears on geocaches that have additional waypoints (like parking or trailheads or stages)

If I enable the additional waypoints, then I get the lines. I know we used to have the waypoints without the lines, so I don't know what has happened.
  •  

Menion

#5
Kristian I'm sorry, but red lines that connect cache with it's waypoints is in Locus since begin. So I'm sure that at least two years. Currently there is no way to disable these lines, but if there will be more people interested in a way to disable these lines for visible waypoints, I may add additional configuration parameter to Locus/config.cfg file ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

kristianmatthews

#6
Thanks menion. They don't bother me enough to make more work for you :) I am happy.
  •  

Menion

#7
no problem, I decided to add it anyway :) ... in next version will be in config file parameter "map_items_gc_waypoints_draw_lines". If you set it to "0", lines will be disabled
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

germangeo

#8
I (formely as "Mike") solved it by reinstalling Locus. I used if for ages and so I could solve another problem with this too - I deleted my two locus folders that I had on different partitions of my SD card.
Unfortunaletly I forgot to backup my traks - but no matter I will record new ones  ;) .
Thank you for this GREAT TOOL !!!!!
  •  

Menion

#9
Hello Mike,
 hmm re-install is also a solution, but not best I think :). Anyway do you have at least some backup? Locus automatically backup it's points/tracks data into Locus/backup directory, so check if you don't have any files from here ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

lml

#10
This bug has been present for a while (maybe already in version 1.10.x) but I have only noticed it at low zoom levels <= 10, which I seldom use. The problem isn't that Locus is showing the red lines but that Locus draws the red lines between wrong coordinates. Maybe it is related to the POI-grouping algorithm as I have only noticed it when I enable POI-grouping.

As you can see in my first image Locus draw the red lines like it is 10km and more between a waypoint and the geocache it belongs to. This is almost never the case in real life. The red lines also seems to converge into different points.

I hope this can help you to solve this bug. Below are my example images.

Zoom level 10 with POI grouping enabled - Locus draws lines all over the place as if the waypoints is many km:s from their geocaches:


Exactly the same position on the map but with POI grouping turned off - the lines go back to normal:


At zoom level 11 all seems normal, both with or without POI grouping:
  •  

Menion

#11
Iml, you're my saviour, thank you, thank you and once more thank you :)

this was the correct source of problems! Handling all these stuffs, waypoints, line, grouped icons etc. is sometimes quite complicated. Seems that I've fixed it now. It needs some more testing, but at least I know exactly where to check for a problems. Perfect
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

karlis

#12
Hi,
as this is my first time writing in this forum, I want to thank for the excellent app! I really enjoy using them.

But I remarked some changes in the last time, which I want to discuss. I like large scale geocaching mysteries and multis therefore I really need theese red lines between cache and its waypoints. However, I can see the waypoints only on a low zoom level (13-18), but not in a higher one. And the red lines can be traced from the waypoint only for restricted distance (not always until the cache). It wasn't the case for some months - I could see waypoints and red lines also in a highest level.
Are those changes deliberate or is this a bug?

And one more thing -  in the right panel there was a possibility for quick select / deselect of points (whole folder). I can't find this button anymore. Is it possible to bring it back?

Thanks a lot

Thank you
  •