Vector maps not working anymore

Started by franc, April 29, 2013, 08:26:45

0 Members and 1 Guest are viewing this topic.

franc

Hello
Since the last update 2.11.0 my vector maps don't work anymore.
I get an error:



What is it?
Frank
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •  

berkley

#1
Most probably you are using "old" maps. Try to refresh your files from the Locus store or download newer ones from somewhere else.
Search before posting!!!
XDA Orbit, HTC Touch HD, SGS1, SGS2, Nexus S, S4 Active, OnePlus One, Innos D6000
OnePlus X
  •  

franc

#2
Good heavens!
Locus doesn't show anymore older maps?
Great :(
Why like this?
Now I need to downgrade locus, if I still want to use my "old" but perfect working maps??
Not a good update then.
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •  

balloni55

#3
similar:
viewtopic.php?f=25&t=3030&view=unread#p20372
menion will fix it soon ;-))
LMC 3.70.0 AFA
Locus Map 4.21.1.1 Gold AFA
LMC User ID c8b19276f
LM4 User ID e06d572d4
  •  

Menion

#4
yes sorry franc, it's not an intent but just a stupid issue. I greatly improved some features around new 0.3.0 maps and these older has some problems with this. In next version it will be ok (will be available soon, probably tuesday)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

franc

#5
Ok, so I just wait for the next update.
No problem then, if backward compatibility is given.
Thank you.
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •  

DougPeterson

#6
I posted a similar problem at https://getsatisfaction.com/locus/topic ... ith_2_11_0

I had created the province maps from a larger country map.  The country map was current and still worked fine in Locus.  I created the province maps using osmosis 0.39.

Thank you,

Doug Peterson
  •  

DougPeterson

#7
The version of the mapsforge-mapfile-writer.jar was 0.24.  I updated to 0.40.1 of osmosis and 0.30 of mapsforge-mapfile-writer.jar and it created a file that Locus worked with.  0.40.1 was the latest version of osmosis that would work with mapsforge-mapfile-writer.jar.  Newer versions of osmosis failed with this plugin.

Thank you,

Doug Peterson
  •  

DougPeterson

#8
The 2.11.1 update has fixed the problem.  Thank you for the quick fix.
  •  

Menion

#9
perfect, thanks for confirmation
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

franc

#10
Yes, it works again
Thank you for the update
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •