slow loading of the vector maps

Started by neum, July 26, 2012, 21:21:04

0 Members and 1 Guest are viewing this topic.

neum

Has anyone the same problem with the slow loading of the vector maps? It's very slow when I zoom into a detailed map like in an area of a city. Online maps load quite faster. Other apps like c:geo also load the vector maps quite faster.
  •  

gynta

#1
for example - which map?

stephan

#2
I see the same slow loading of vector maps in Map-Menu when chosing Vector folder, even if the map and locus are in flash-RAM of mobile phone (which should be a bit faster)
e.g. in viewtopic.php?f=43&t=1839
Germany 2012-05-26 (698 MB) https://docs.google.com/open?id=0B3Ijv5 ... XAxOEN1ZGM
or
Austria Switzerland Austria+Switzerland 2012-05-22 (292 MB) https://docs.google.com/open?id=0B3Ijv5 ... FBweWJmSUE

It seems as if Locus wants to read the whole map (and verify it's working) before it shows all maps. :?:

The slow showing of list of installed vector maps happens only after changing from a non-vector-map to vector-map folder. It takes about 30 secs until all vector-map folders (and the maps) are listed.
  •  

Menion

#3
hmm we talk hear about slow loading (displaying) vector maps on map screen or slow loading of list of vector maps? 30s is really terrible anyway - how much vector maps is locus displaying?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Nadja

#4
On my phone, the rendering of the vector maps is actually very fast, but the startup-time of Locus is around 1 min. I'm using the abovementioned map of Germany and the startup goes like this:

White screen (~10s)
Automatische Sicherung Intitialisierung... Eigene Karten (~50s)  (something like: Automated backup initializing... own maps)
And then the rest is just *boof* in 0.5s

Is there anything I can do to speed this up? Using online-maps, the startup is a matter of 3s max :(
  •  

Menion

#5
Hello Nadja,
  you wrote that using "online-maps" is fast. This mean that when you select Online map, close Locus, wait a while (at least 5 seconds), start Locus, is faster? then same process with vector maps? I think it's not possible, really

  there are two way that may cause long start

1. automatic backup
2. initializing of the maps

Is necessary to check what cause it. So I suggest firstly disable automatic backup feature in "menu > function > backup manager > and at bottom, "Cancel" ". Don't forget to wait a while between starts.

Second case should be that in your map directory is at least one map, that is not visible in Locus list of maps. There should be a problem with initializing and map do not work correctly. So please check if really all maps in your map directories, are visible in Locus.

If non of this helps, you may create for me long log by this method http://docs.locusmap.eu/doku.php/manual ... og_message. There will be maybe some clue why this happen to you
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Nadja

#6
Hello all!

So I found what was causing the error: The map was in the root-directory of c:geo which creates 1 sub-dir for every known geocache. Since I have saved around 5.000 geocaches, this might have slowed down things alot. I moved the map to its own directory and voilĂ : startup in <3s. Sorry to have taken your precious time, I should have tried that before  :?
  •  

Menion

#7
hmm Locus was probably searching for some additional maps in all subdirectories.

Good to know, thanks for information and enjoy Locus :)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •