Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - reha73

Pages: 1 [2] 3
16
Ich bearbeite die Datei lieber vor dem Import. Also einfach die gpx-Datei auf dem PC mit einem brauchbaren Editor öffnen, und einen beliebigen Namen eintragen:
Code: [Select]
...
  <trk>
    <name>Track XYZ</name>
...


   

17
Das ist ein bisher ungelöstes Problem, das schon an anderer Stelle diskutiert wurde: http://forum.locusmap.eu/index.php?topic=4473

Die App OsmAnd kann zB damit umgehen (hat aber dafür andere Nachteile, die dich aber ja nicht unbedingt betreffen  oder stören müssen). Was mich bei OsmAnd am meisten stört: Man kann die automatische Neuberechnung der Route nicht deaktivieren. Diese versaut einem aber mitunter die komplette Route:
- Verlässt man den Track, wird also immer neu berechnet, die Ergebnisse sind oft sehr schlecht und komplett anders, als bei der ersten Berechnung. Das liegt vermutlich daran, dass OsmAnd bei der Neuberechnung immer den nativen Router benutzt und nicht etwa Brouter, das ich sonst zur Berechnung nutze.
- Verlässt man den Track gar auf einem Weg, der in den OSM Karten nicht verzeichnet ist, was im Ausland häufiger der Fall ist, dreht die Neuberechnung komplett durch, verweilt meist in einer Endlosschleife, weil kein Weg zurück auf den Track zu finden ist.
Die weitere Diskussion würde wohl diesen Thread sprengen.

18
Bin auch wenig angetan von dem neuen "Feature" und habe ausführlich getestet. Es ist genau wie Ulli sagt: Es werden die Werte aus der Einstellung Verschiedenes / Daten Import / Trackfarbe und Transparenz übernommen.
Das gilt auch für Tracks, die in Locus selbst erstellt wurden, also rein gar nichts mit "Import" zu tun haben. Ist hoffentlich nur ein Bug und kein Dauerzustand.

19
Ich nutze auch Sygic fürs Straßenmoped und habe genau aus dem von dir beschriebenen Grunde alle möglichen Alternativen ausprobiert und letztlich viele Stunden damit verschwendet. Daher mein Tipp: Bleibe bei Sygic.
Wenn du doch unbedingt etwas anderes testen möchte, dann versuche eher Osmand als Locus. Die Navigationshinweise sind da deutlich besser. Aber dennoch schlechter als in Sygic.

Noch ein Hinweis zu Locus: Ich erhalte durchaus Navigationshinweise. Dazu exportiere ich die Route aus dem Motoplaner allerdings direkt als GPX-Track. Den Track dann in Locus laden und auf Navigation klicken. Dann öffnet sich eine Dialogbox, in der ich die Anzahl der gewünschten Navigationshinweise wählen kann.


Das was bei der Reiseroute in den Klammern steht, wird dann als Sprachansage ausgegeben.

20
was ich also möchte,  ist das die Planungsphase Speicherbar über gewisse wenige Stützpunkte ist.
Das geht nur, wenn du speicherst, bevor die Route berechnet wird. Also nur die "Orientierungspunkte" setzen und dann speichern. Das ist dann aber leider ziemlich sinnlos, denn zumindest ich kenne keinen Weg, diese dann lediglich per Luftlinie verbundenen "Orientierungspunkte" nachträglich als Route berechnen zu lassen.
Da würde ich mir einen Online-Routenplaner suchen, der das kann. Ich denke, dass http://radservice.radroutenplaner.nrw.de/rrp/nrw/cgi?lang=DE genau das kann, was du suchst. Allerdings nur für NRW. Ähnliches sollte es aber auch für den Restt der Republik geben. Ist jedenfalls sehr intuitiv zu bedienen und die Entwürfe können lokal gespeichert werden.

21
Gute Idee, das noch mal ans Licht zu holen. Das Problem hat nämlich auch in der aktuellen 3.7 PRO noch Bestand. Und auch der beschriebene Workaround funktioniert so nicht.
Die besagte Meldung erscheint zumindest immer dann, wenn man versucht, entlang eines importierten gpx-Tracks zu navigieren. Dann wird nämlich nicht der Dialog mit der Profilauswahl geöffnet (was auch eine gewisse Logik hat) und also immer der KFZ-Modus gewählt. Das ist zunächst auch nicht weiter schlimm, weil ja, wie schon beschrieben, erst einmal richtig navigiert wird, nämlich entlang des Tracks, egal ob dessen Wege von KFZ befahren werden können oder dürfen.
Sobald man aber den Track verlässt und die Route manuell oder automatisch neu berechnet wird, ist sie dahin. Dann erfolgt die Neuberechnung nämlich tatsächlich im KFZ-Modus. Und dann eben nicht mehr entlang des Tracks, auch nicht zurück zu diesem, sondern direkt zum Ziel. Und das eben nur noch entlang von KFZ-Straßen und -Wegen. Locus verlässt also den Track jetzt komplett, lässt selbst nach der Rückkehr auf den ursprünglichen Track keine Fahrt mehr auf für KFZ gesperrten Wegen zu.
Man kann an dieser Stelle natürlich die Navigation neu starten, dann stimmt wieder alles.
Ein gewisser Workaround hierbei wäre es auch, die Profilzuordnung in Brouter so zu ändern, dass das gewünschte Navigations-Profil (also etwa "trekking") dem KFZ-Modus zugeordnet wird. Dann erfolgt die Neuberechnung zwar immer noch nicht entlang des Tracks, aber immerhin im gewünschten Modus.

Wenn man in Locus die Route online (YOURS, alle Dienste ...) neu berechnen lässt, ist das Problem gleich. Es wird auch dann im KFZ-Modus berechnet. Die Ursache ist also wohl nicht in Brouter, sondern in Locus zu suchen.

Zusammengefasst sehe ich hier 2 Probleme:
1) Locus ordnet importierte Routen und Tracks keinem Profil zu.
2) Bei der Neuberechnung der Route werden Weg- oder Trackpunkte (Zwischenziele) ignoriert, zumindest nicht an Brouter übergeben.

22
@gynta
Habe es mit den Locus Vektorkarten NL,D,B getestet. Damit funktioniert der automatische Kartenwechsel in der Tat (die Karten gefallen mir aber nicht, oder kann man zumindest die Radwege ausblenden?).

@Christian
Die Locus Vektorkarten haben tatsächlich einen Randbereich.

@jusc
Ein Beispiel mit den Mapsforge Karten?
1. Bild: GPS aus, verschiebe Kartenmitte nach NL (etwa mit der Absicht eine Route zu erstellen), nur die D-Karte wird angezeigt.
2. Bild: Spiele mit den Zoomstufen hin und her, dann wird auch NL angezeigt (Zoomänderung per Fingergeste verschiebt irgendwann den Cursor ins Landesinnere, so dass die Karte nachgeladen wird; Zoomänderung per Tasten verschiebt den Cursor nicht und bewirkt also auch kein Nachladen der Karte).
3. Bild: Bewege den Cursor so weit nach NL, dass die D-Karte aus dem sichtbaren Bereich verschwindet, schalte GPS ein ("virtuelle" Position in D per "FakeGPS") und zentriere die Ansicht zur GPS Position: D-Karte wird nicht eingeblendet.
4. u. 5. Bild: Schalte GPS wieder aus, D-Karte wird weiterhin nicht eingeblendet.
6. Bild: Hinzugefügt, damit man auch sieht, dass die Kartenmitte wieder in D ist. Was man hier auch sieht: Nach über 10 Minuten Ruhe ist noch kein Element der D-Karte zu sehen, da kommt auch nichts. Liegt also nicht an der Hardware.

Zu "FakeGPS" sei noch angemerkt: Ich bin ungefähr diese Strecke heute real gefahren, da wurde die Karte auch nicht automatisch eingeblendet, es wird also nicht an den virtuellen Spielchen hier liegen.

7. Bild: Jetzt verschiebe ich die Kartenmitte >50km nach D: Karte wird eingeblendet.
8. Bild: Jetzt verlege ich die GPS-Position weit nach B: Karte wird eingeblendet.

Fazit: In Grenznähe funktioniert der Kartenwechsel nicht, in weiterer Entfernung aber schon.

23
Zumindest die Mapsforge Karten haben nicht mal 1km Rand. Sobald ich die Grenze passiert habe, muss ich die Karte wechseln. Auf dem Motorrad heißt das: anhalten, Handschuhe aus, Handy aus der Hülle kramen, Karte wechseln, wieder alles einpacken und auf dem Rückweg schon wieder. Geschweige denn, wenn ich während einer Tour mehrfach die Grenze passieren muss ...
Und: Wie soll man denn eine grenzüberschreitende Route planen, wenn immer nur eine Karte eingeblendet wird?
Es sollte doch technisch möglich sein, einfach mehrere Karten gleichzeitig einzublenden.
Ich habe bis vor Kurzem OsmAnd benutzt. Da gab es das Problem nicht (aber natürlich andere).

24
2) WENN es das denn tut: der Auslöser für den Kartenwechsel ist definiv fehlerhaft in Locus. Ich nehme an, Menion hat das umfassende Rechteck einer Vektorkarte als Entscheidungskriterium genommen statt das Polygon der Kartengrenze auszuwerten ...
Ich bin heute über die holländisch und belgische Grenze gefahren: Nichts, also auch in der Realität kein Kartenwechsel. Allerdings war ich nur jeweils etwa 10km hinter der Grenze. So wie der Grenzverlauf hier ist, könnte es gut sein, dass wir außerhalb eines solchen Rechteckes liegen (der Zipfel im Süden Hollands).

Daher habe ich gerade mal die GPS Position mit "FakeGPS" virtuell weiter ins Land hinein verschoben. Und siehe da: Die Karte wechselt automatisch! In alle Richtungen, in alle Länder. Du scheinst also Recht zu haben mit deiner Annahme.

Damit kenne ich zumindest die Ursache und werde halt damit umgehen müssen.
Danke.

25
Problem 1. war mir bei der letzten Autofahrt auch aufgefallen.
Karte drehen habe ich aktiviert.
Dadurch wurde die Karte ziemlich unruhig auf dem Bildschirm, war ständig in Bewegung und die
Fahrtrichtung auch nie zum oberen Bildschirmrand ausgerichtet.
Die Unruhe kommt, so war es zumindest bei meinem Gerät, von der Einstellungen der Sensoren. Ich weiß nicht mehr genau, was ich da geändert habe, könnte dir allenfalls meine aktuellen mitteilen. Die Einstellungen dürften aber ohnehin Geräte- und Anwendungsspezisch unterschiedlich sein, sonst gäbe es sie ja nicht. Einfach mal vorsichtig eine nach der anderen ändern.

26
GPS ist in Locus deaktiviert (Sat-Symbol ist weiß), wenn ich die Karte jetzt verschiebe, wird, in meinem Fall die Hollandkarte, nicht geladen.

27
Ja, das ist gesetzt.

28
ja cool, habe den Button bei mir übernommen und das klappt. Danke!

29
[DE] - deutschsprachiger Forumsbereich / Re: Routenplanung???
« on: February 21, 2015, 19:17:51 »
"From"/"To" musst du kleine schreiben, also from/to.

Für die Routenplanung in Locus: Nach dem Einfügen des ersten Wegpunktes zunächst das dritte Icon von Links (Navigation) anklicken und die gewünschten Optionen einstellen, erst danach die weiteren Wegpunkte mit der + Taste hinzufügen. Bei jedem neu hinzugefügten Punkt rechnet Brouter jetzt die Verbindung aus.

30
So das Dashboard klappt jetzt, hatte ich wohl nicht strukturiert genug mit den Einstellungen gespielt (es lag wirklich am Häkchen "obere Titelleiste ..."). Sorry.

Hier der gewünschte Screenshot zu dem Costum-Screen-Problem:



Die blaue Leiste oben bleibt im Bild. Hier sehe ich leider kein Option, die sich auf die Titelleiste bezieht.

Pages: 1 [2] 3