Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - zsero

Pages: 1 [2] 3 4
16
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 04, 2012, 00:27:34 »
From the old one, I only kept maps and mapsVector, my points were just exported to a GPX. I think I cannot help diagnose what was the original case, but now at least I have a fast and clean Locus.

17
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 04, 2012, 00:19:04 »
Database

18
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 04, 2012, 00:06:36 »
OK, uninstalled Locus. My /data is empty. I've renamed the /sdcard/Locus to something else. I've done now a full search for "locus" on / and there is no Locus anywhere. I did a Dalvik + Cache format in recovery.

Aaaaaaaaand it's working! I got the startup wizard!

19
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 03, 2012, 22:50:10 »
gynta, I've just deleted all of them, going crazy about the duplicate issues. They were quite small, just having some 100 points in them. I'm still trying to make Locus Pro do a clean start, and I cannot make it. The initial sequence what runs in Locus Free doesn't want to run.

20
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 03, 2012, 22:08:57 »
OK, I'm doing the conversation now with free. Why not just make a debug option to convert database manually? Similar to clear cache, clear map data, etc. But don't forget not everyone knows english or is enthusiast enough to come here.

An idea: when I started Locus Free it asked me all the first start-up questions. From this I believe that the detection bug is somewhere in the Locus Android settings, not on the sd-card contents. I'm quite sure that if I'd reseted Locus Pro, it would have asked me the data conversion too.

edit:
OK, long long conversion process done. Categories show up in Locus Pro. But I tried to create a new category and then now all categories appeared twice! Maybe it's best to start from a clean data dir.

edit
menion, I'm trying to reinitialize Locus Pro, but there is no way to do it! I renamed the data dir, removed the data from Locus in Android, deleted the cache within Locus, asked it to reset itself, and I even formatted Dalvik + cache. Still Locus Pro starts without asking me the first questions!

21
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 03, 2012, 18:02:30 »
OK, starting the file you've sent me asks the Delete Old, Close, Delete New dialog. I choose close.

Old Locus still believes it's empty.

Files here:
https://www.dropbox.com/sh/l9n7x9u76p2seez/uEbB6FIyye

22
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 03, 2012, 17:01:38 »
Installed 2.7.2 Nothing changed. It doesn't list the categories on startup after deleting cache.

23
Troubles & Questions / Re: 1.6.1 deleted everything!
« on: November 03, 2012, 15:08:09 »
Sorry, I mixed up the numbers. So I had 2.6. something and I updated to 2.7.1.

I didn't receive any request for converting the data. Locus started like usual.

I don't know how to reinstall something on Gingerbread, I'm afraid of loosing all my settings if I do uninstall and install. Also, if it gets fixed by a reinstall then I cannot help you to make a fix for Locus 2.7.2. So I think it would be better if I could help you by installing versions you send me and tell if it's fixed. I have a rooted phone, it's not a problem. I can send you my database files, if you tell me which ones to send.

If you have a lot of users out there with this problem then I think it's important to make a quick fix for 2.7.2.

24
Troubles & Questions / 1.6.1 deleted everything!
« on: November 03, 2012, 08:32:45 »
I've just updated from 1.5.x to 1.6.1 and now all my tracks and points and categories are gone! The files are still there in sdcard/Locus. Maps are OK.

I just wanted to report how much I like the new category dialogs, but it seems that the merging didn't happen well! Can you send me some versions from 1.5.x to try to re-install that and see if I can get back the data? I'd be happy to help debugging!

25
Troubles & Questions / Re: "My Maps" import brakes navigation
« on: October 23, 2012, 15:20:02 »
Oh, so we should write a plugin for that... Problem solved :-) You have no control over what happens inside your plugins (or you can say so).

26
Wishlist / Re: gpx mass import
« on: October 23, 2012, 14:43:36 »
I've raised a similar feature here: https://getsatisfaction.com/locus/topic ... zip_folder

As part of my idea, mass-import could be integrated there from zip or folder.

27
Wishlist / Re: Creating category on import
« on: October 23, 2012, 14:41:33 »
I've raised a similar feature here: https://getsatisfaction.com/locus/topic ... zip_folder

I think it's similar to your idea, feel free to join.

28
Wishlist / Re: Re-thinking the whole database / visible elements part
« on: October 23, 2012, 14:39:52 »
Posted it on get. Btw, from current most recent 5 wish-list threads, 2 of them could be solved this way
https://getsatisfaction.com/locus/topic ... zip_folder

29
Troubles & Questions / Re: "My Maps" import brakes navigation
« on: October 23, 2012, 14:18:10 »
Oh, I see. So once Google ends the Maps API the My Maps will be removed.

For the Directions API, I have a suggestion. OK, don't risk an API key for Locus, but you can let us use a or own API key (for example from a text file). I mean if I decide to watch any map other than Google Maps with it, it's my fault, in the worst case they might revoke my key. I know this way it's a power-user option, but it wouldn't need to be enabled by default and there could be a howto in the forum how to get a API key and save it into a file.

30
Troubles & Questions / Wireless location not working with navigation
« on: October 22, 2012, 21:29:14 »
This is the most common usage scenario for devices with wifi-only capabilities: You are at home, at the wireless network. You need to go somewhere so you generate a navigation path there. The only thing you know is where do you go, nothing else. You don't have GPS signal, as you are indoors.

The problem is that the navigation now has some bug and it doesn't take wireless information into account, only GPS. Even though it asks for "confirm using wireless position" or something similar. But after it, it doesn't use it. It starts looking for GPS. The only way now is to actually hack it with "map center" or with creating a temporary point where you are. None of them really easy.

I'd recommend two things:
1. Fix this bug and use wireless just like GPS and how it should work. Rename the GPS setting to "My Location". It's even better as Google Maps uses now "My Location" in the direction planning, making it easier for users to find it.
2. Make the default setting in the From part to be "My Location". Obviously you're most likely to plan from My Location, if not, you are using some advanced track planning way (i mean new track, + point, + point, +, +, navigate).

Pages: 1 [2] 3 4