Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Hadubrand

Pages: [1]
1
I have already started this topic in the German-speaking forum but can not believe the final answer.

I have problems to export recorded GPX tracks to the ext. SD card (64 GB). I mean, that was formerly not like that.

My device: Samsung Galaxy S8+, latest updates, Android 9.

I left the main directory on the internal SD, as recommended, configured the export directory and the backup directory to <ext-SD>/_LOCUS/export respective <ext-SD>/_LOCUS/ backup. If I try to export a GPX track recorded by Locus, locus reports 'operation not successful'.
If I reset the setting of the export directory to the main directory, i.e.
/storage/emulated/0/Android/menion.lodus.pro/files/Locus/export, the export works.

The backup, on the other hand, works, i.e. Locus is principally able to write the external SD.

What happened, or what am I doing wrong?

I also have a similar problem with my older Samsung Galaxy S5 (Android 6) which I use normally during my bicycle tours. Due to poor internal storage capacity I set the Locus main directory to the external SD-card. The export does not work to a special export folder <ext- SD>/_LOCUS/export, nor to the standard (default) export directory, i.e. <ext-SD>/Android/data/menion.locus.pro/files/Locus/export.
In both cases, I get 'operation unsuccessful'. What do you recommend?

Best regards
Ulli

2
[DE] - deutschsprachiger Forumsbereich / Export von Tracks
« on: July 05, 2019, 19:45:45 »
Seit kurzem habe ich plötzlich Probleme, meine GPX-Tracks auf die ext. SD-Karte zu exportieren.
Mein Gerät Samsung S8+, aktuelle Updates.
Das Hauptverzeichnis habe ich auf der int. SD belassen, das Export-Verzeichnis auf <ext-SD>_LOCUS/export konfiguriert. Beim Export meldet Locus 'Vorgang nicht erfolgreich'. Das Backup-Verzeichnis habe ich auch auf die ext. SD gelegt und zwar auf <ext- SD>_LOCUS/backup. Der Export funktioniert, d.h. Locus kann meine ext. SD beschreiben.
Erst wenn ich das Export-Verzeichnis wieder in das Hauptverzeichnis, also
/storage/emulated/0/Android/menion.lodus.pro/files/Locus/export konfiguriere funktioniert der Export. Was ist passiert, bzw. was mache ich falsch?
Gruß Ulli

3
Nachdem mein Tablet ein Update auf Android 5.0 bekommen hat, wollte ich nachfolgendes nachvollziehen, bin aber bisher gescheitert.

*******************
Changes in Android 5.0

Android 5.0 partially loosens strict permissions of applications writing on SD cards. After a week of extensive work we managed to enable storing vector maps, SRTM data and backups on SD card. All other Locus folders must remain in the internal memory, it is not possible to run them on SD card without issues.

Works since Locus Map 3.11.0

If you have a device with SD card and want to save some storage space, follow these instructions:

go to Menu > Settings > Miscellaneous > Default directories
set new location of Locus/mapsVector, Locus/backup and Locus/data/srtm directories on SD card
restart Locus Map
*****************

Hinweis: Bisher nutzte ich die Methode des Hinzufügens eines Verzeichnisses für Offline-Karten auf der ext. SD und habe den gesamten Rest im Programmverzeichnis belassen, wie für KitKat beschrieben, das funktionierte. Meine Locus-Version ist 3.12.2.

Nun meine Fragen:

Sind die 3 Verzeichnisnamen auf der ext. SD beliebig?

Dürfen sie in einem Unterverzeichnis stehen und müssen wie auf der int. SD mit /Locus beginnen, oder muss es ein anderer Name, z.B. /_LOCUS sein oder müssen sie sogar in der Root der ext. SD stehen?

Dürfen die Verzeichnisse zuerst mit einem Dateimanager erzeugt werden um sie anschließlich in Locus zuzuweisen oder müssen sie in Locus erzeugt werden?

Müssen alle 3 Verzeichnisse auf der ext. Karte stehen oder darf z.B. auch nur mapsVector und backup dort stehen. Hintergrund dieser Frage ist, dass es nach dem anschließenden Kopieren des Inhalts von SRTM data außerhalb Locus beim Neustart von Locus jede Menge Fehlermeldungen gab. Allerdings habe ich die 3 Verzeichnisse innerhalb Locus direkt in der Root der ext. Karte angelegt, was zweifelsfrei unschön ist.

Kann mir jemand helfen?
Gruß, Ulli

4
[DE] - deutschsprachiger Forumsbereich / Locus (pro) Widget
« on: June 23, 2015, 16:29:13 »
Hallo miteinander,
in der aktuellen Version fällt mir auf, dass das Widget (4x1) nicht immer bereit ist, d.h. nichts passiert, wenn ich auf ein Icon tippe. Man sieht das optisch am Widget gleich daran, dass im Ruhezustand sowohl Start als auch Pause aktiv sind. Wenn es funktioniert, ist im Ruhezustand Pause ausgegraut, Start grün und außerdem steht bei der Entfernung und bei der Zeit jeweils 0. Ich habe festgestellt, dass das Widget beim Entfernen und sofortigem Neuanlegen wieder funktioniert.
Was kann der Grund für dieses Verhalten sein? Ob das auch schon früher so war, weiß ich nicht, da ich das Widget erst jetzt öfters nutze. Möglicherweise passiert es auch nur dann, wenn man zuvor die Locus-App am Laufen hatte.

widget-OK | widget-notOK.


Gruß
Ulli

5
Das Thema wurde bereits andiskutiert:
http://forum.locusmap.eu/index.php?topic=4534.new;topicseen#new

Bei der derzeit aktuellen Version 3.8.0 ist mir folgendes aufgefallen: Bei aktivierter Wegführung eines gespeicherten Tracks wurde bisher rechts neben dem Wegführungssymbol die Entfernung zum Ziel angegeben. Ich weiß jetzt gar nicht mehr, ob man früher einstellen konnte, was dort angezeigt wird. Zumindest jetzt können nebeneinander 2 verschiedene auswählbare Werte angezeigt werden (z.B. Entfernung zum Ziel, Höhe etc). Stelle ich Entfernung zum Ziel ein, steht dort immer 0 m, obwohl Locus die Entfernung bekannt ist, was man beim Aktivieren der Zielführung (auf den Track tippen) im aufpoppenden Fensterchen sehen kann. Ich vermute mal, dass das ein Fehlerchen ist. Klar, die Zeit bis zum Ziel kann nicht angezeigt werden, wenn im Track kein Zeitprofil gespeichert ist, daher steht dann dort Unbekannt, das ist OK.

Gruß
Ulli

6
Das Thema wurde bereits andiskutiert:
http://forum.locusmap.eu/index.php?topic=4534.new;topicseen#new

Bei der derzeit aktuellen Version 3.8.0 ist mir folgendes aufgefallen: Beim Aktivieren der Wegführung ändert sich die Trackfarbe/Stil gegenüber der Trackfarbe, die vor der Aktivierung ausgewählt war (sofern es eine andere war). Das war bisher nicht so, bisher wurde die Trackfarbe/Linienstil des Tracks auch in die Zielführung übernommen. Man kann zwar die Farbe und den Linienstil bei Trackinfo (beim Klick auf den Track während der Zielführung) ändern, das wird aber nicht gespeichert, sondern muss bei jedem Start der Zielführung neu gemacht werden. Das ist schade, denn beim Radfahren bei Tages-/bzw. Sonnenlicht ist das Display eines Smartphones sowieso im allg. schwer abzulesen. Daher habe ich bei mir für den Track-Ordner Magenta und Pfeile 1 mit 12 px Breite eingestellt, weil sich das ziemlich gut vom Kartenhintergrund der von mir ausschließlich verwendeten Vektorkarten abhebt und außerdem durch die Pfeile die Fahrtrichtung angezeigt wird.
Bei Einstellung/Routenführung habe ich keine entsprechende Einstellung für die Trackfarbe/Stil gefunden. Stattdessen werden offensichtlich die Werte aus der Einstellung Verschiedenes / Daten Import / Trackfarbe und Transparenz übernommen. Dort gibt es keine Einstellung des Linienstils und mit Import hat es eigentlich auch nichts zu tun, denn der Track ist ja schon importiert, sondern wird nur ausgeführt.

Gruß
Ulli

7
[DE] - deutschsprachiger Forumsbereich / Zielführung mit TTS
« on: April 19, 2015, 13:21:24 »
Die Zielführung ist mittlerweile gegenüber früher deutlich besser und recht brauchbar geworden :-)
Wieder ein Grund mehr, Locus als alternativlos zu bezeichnen!!

Nur fällt mir auf, dass die Abbiegehinweise oft sehr spät kommen (in 10m, 5m), manchmal erst, wenn man bereits abbiegt. Ich vermute, das ist der Preis für die Verbesserung. Für meinen Geschmack sind immer noch zu viele unnötige Hinweise 'in 10 m dem Straßenverlauf folgen' und beim kleinsten Knick des Tracks zwischen zwei Trackpunkten 'in 10 m links halten', während entscheidende, rechtwinlkige Knicks oder Abbiegevorgänge manchmal gar nicht, manchmal erst unmittelbar nach der Abbiegung gemeldet werden.

Gerade kam ein Update auf 3.8.0 bei dem u.v.a. event. Verbesserungen auch in diesem Bereich angegeben wurden (Guidance now automatically search for optimal places for notifications). Ich kann morgen testen, ob es eine Verbesserung gab und berichten.

Frage an den Autor Menion: Gibt es mittlerweile eine Korrelation zwischen Track und dem (Rad-)Weg?

Grüße
Ulli

8
Abgesehen davon, dass die Sprachausgabe Taktabweichung z.B. 300 m, 8 Uhr etwas seltsam ist, würde ich gerne wissen, wie 8 Uhr zu interpretieren ist. Ist es als Winkel von der Nordrichtung zu verstehen, also in diesem Fall OSO oder aus Bewegungsrichtung (12 Uhr ist geradeaus, 8 Uhr nach links etwas zurück?
Grüße
Ulli

9
Mein Tablet (Samsung Galaxy Tab 4 10.1) hat zwar einen GPS-Empfänger aber keinen Kompass. Das heißt, die Karte kann sich nicht drehen, wenn ich das Tablet nur (ortsfest) drehe. Wie muss ich mein Locus Pro konfigurieren, dass sich die Karte beim Gehen/Fahren in Bewegungsrichtung dreht? Oder geht das bei Locus nicht ohne Kompass?


Gruß
Ulli

10
[DE] - deutschsprachiger Forumsbereich / Track Kartendarstellung
« on: October 12, 2014, 15:46:13 »
Hallo miteinander,
in einer der letzten Versionen von Locus pro wurde die Trackdarstellung (Trackliste/Karte) überarbeitet. Seither wird ein gespeicherter Track initial mit einer recht breiten (32 px) roten Linie angezeigt. Diese kann man zwar ändern, auch auf den Ordnerstil, ich habe aber keine Einstellung gefunden, bei der man die initiale Darstellung (derzeit 32 px breite rote Linie) konfigurieren kann. Habe ich etwas übersehen?
Gruß
Ulli

11
Beim Profil Fahrrad habe ich eingestellt
10m / 5s  / Distanz UND Zeit / 100 m (GPS-Genauigkeit).
Aufzeichnung eines Punktes nur bei Geschwindigkeit > 0.

Die Aufzeichnung ist recht ungenau, weil zu wenig Punkte aufgezeichnet werden, so dass an manchen Stellen der Weg nicht nachvollziehbar ist. Siehe Beispiel. Der GPS-Empfang war hervorragend.

Was habe ich falsch gemacht?

Gruß
Hadubrand

12
Troubles & Questions / TTS unsatisfactory
« on: July 11, 2013, 18:18:29 »
During hiking and cycling i want to be guided along a track. In this case it is not very practical to look permanently resp. very often at the screen. Therefore I tried to use TTS. It works fine if the the waypoints of the track are relatively far away from another (more than 100 meters) and if a waypoint requires a 90 deg turn. It often doesn't work correctly if the way requires a zic-zac (e.g. 1st right, the left). In this case the initial turn may be not announced or the 2nd command may be missing.

Another observation: If you leave the guided track and follow another way which leads finally back to the track, TTS doesn't give an alert if you approach the track again, even if you cross the track you get no alert to turn.

Did I make something wrong? If not, what is the reason for this behaviour? Can it be changed?

Greetings

Pages: [1]