Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Hadubrand

Pages: [1] 2 3
1
Hi Ulli,

I do not think the size of the external sd-card is the problem.

On my Samsung Galaxy Note4, running Android Stock ROM 6.0.1, I have an extenal 64GB sd-card installed.
Downloading LoMaps to this sd-card or running backups from Locus on the external sd-card works as expected without any problem.
Even my "backup device", a Samsung Galaxy S4, running Android 5.0.1 Stock ROM, do not have any problems with its installed 64 GB external sd-card when downloading LoMaps or running backups from Locus to the external sd-card.

Would you start a feature request at Locus HelpDesk? My vote is sure for that feature.
Or should I start the feature request at Locus HelpDesk?

Yours
Stefan

PS: Forgot to mention, that the folders on the external sd-cards are named ""/extLocus/backup/" and "/extLocus/mapsVector". I. e. Folders created by me. I wrote  read somewhere that Locus might get problems, if the root-folder on external sd-card also named "/Locus/".
Hi Stefan, I found the problem in a thread on the Help Desk and an answer of Menion.
https://help.locusmap.eu/topic/exporting-tracks-process-unsuccessful
I posted a comment to this thread.
Yours
Ulli

2
Sorry, the default folder I stated had two spelling errors, it is really
/storage/emulated/0/Android/data/menion.android.locus.pro/files

Hopefully without errors this time.

I think, it is really a feature request, also with respect of  my S5 where the export folder in Locus' main directory, i.e.
/storage/SD-ID/Android/data/menion.android.locus.pro/files/Locus/export cannot be written.

Is perhaps the size of my 2 SD cards the cause of the problem? Both have 64 GB.

Regards
Ulli

3
I have already started this topic in the German-speaking forum but can not believe the final answer.

I have problems to export recorded GPX tracks to the ext. SD card (64 GB). I mean, that was formerly not like that.

My device: Samsung Galaxy S8+, latest updates, Android 9.

I left the main directory on the internal SD, as recommended, configured the export directory and the backup directory to <ext-SD>/_LOCUS/export respective <ext-SD>/_LOCUS/ backup. If I try to export a GPX track recorded by Locus, locus reports 'operation not successful'.
If I reset the setting of the export directory to the main directory, i.e.
/storage/emulated/0/Android/menion.lodus.pro/files/Locus/export, the export works.

The backup, on the other hand, works, i.e. Locus is principally able to write the external SD.

What happened, or what am I doing wrong?

I also have a similar problem with my older Samsung Galaxy S5 (Android 6) which I use normally during my bicycle tours. Due to poor internal storage capacity I set the Locus main directory to the external SD-card. The export does not work to a special export folder <ext- SD>/_LOCUS/export, nor to the standard (default) export directory, i.e. <ext-SD>/Android/data/menion.locus.pro/files/Locus/export.
In both cases, I get 'operation unsuccessful'. What do you recommend?

Best regards
Ulli

4
[DE] - deutschsprachiger Forumsbereich / Re: Export von Tracks
« on: July 11, 2019, 10:43:40 »
Hallo,

ab Android 5 lassen sich nur Karten, Höhendaten und Backups auf die SD Karte verschieben.
Siehe hier und hier.

Da sich das Verzeichnis ohne Fehlermeldung auf die SD legen lässt, bin ich auch schon darauf hereingefallen.
Ich danke Dir. Nur meinte ich, dass es schon einmal gegangen sei, aber vielleicht ist das auch nur 'historisches' Wissen. Was mich allerdings wundert, ist, dass der Export auch bei meinem S5 (Android 6) nicht geht, bei dem ich wegen Speichermangel das Hauptverzeichnis von Locus auf das von Locus vordefnierte Verzeichnis auf der SD gelegt habe und der Export selbst ins vorgegebene Standardverzeichnis für Export nicht geht. Daher dachte ich schon an einen Bug.
Viele Grüße
Ulli

5
[DE] - deutschsprachiger Forumsbereich / Re: Export von Tracks
« on: July 06, 2019, 09:12:44 »
Ich frage mich immer warum die Leute ein Export auf die SD machen. Denn wenn das Handy mal weg ist sind sie dort auch nicht sicher., bzw. sie sind genauso weg. Ich exportiere auf google Drive. Da sind sie super sicher und jederzeit greifbar. Außerdem habe ich sie dann auch gleich auf dem Rechner.
Darum geht es mir aber hier nicht. Locus bietet den Export auf ein spezielles Export-Verzeichnis standardmäßig innerhalb seines Hauptverzeichnisses an, das sich in den Einstellungen auch auf die SD konfigurieren lässt. Das geht offensichtlich nicht und ich frage mich warum. Möglicherweise handelt es sich dabei um einen Bug, zumal sich das Verzeichnis für Backup durchaus erfolgreich auf die SD-Karte konfigurieren lässt.

6
[DE] - deutschsprachiger Forumsbereich / Re: Export von Tracks
« on: July 05, 2019, 20:13:13 »
Ein vergleichbares Problem habe ich auch mit meinem S5. Bei dem habe ich das Hauptverzeichnis auf die ext. SD konfiguriert. Der Export funktioniert weder bei der Grundeinstellung des Export-Verzeichnisses also auf <ext. SD-Karte>/Android/data/menion.locus.pro/files/Locus/export.noch bei der Konfiguration des Export-Verzeichnisses als <ext. SD-Karte>/_LOCUS/export. In beiden Fällen erhalte ich 'Vorgang nicht erfolgreich'.
Komisch.
Gruß
Ulli

7
[DE] - deutschsprachiger Forumsbereich / Export von Tracks
« on: July 05, 2019, 19:45:45 »
Seit kurzem habe ich plötzlich Probleme, meine GPX-Tracks auf die ext. SD-Karte zu exportieren.
Mein Gerät Samsung S8+, aktuelle Updates.
Das Hauptverzeichnis habe ich auf der int. SD belassen, das Export-Verzeichnis auf <ext-SD>_LOCUS/export konfiguriert. Beim Export meldet Locus 'Vorgang nicht erfolgreich'. Das Backup-Verzeichnis habe ich auch auf die ext. SD gelegt und zwar auf <ext- SD>_LOCUS/backup. Der Export funktioniert, d.h. Locus kann meine ext. SD beschreiben.
Erst wenn ich das Export-Verzeichnis wieder in das Hauptverzeichnis, also
/storage/emulated/0/Android/menion.lodus.pro/files/Locus/export konfiguriere funktioniert der Export. Was ist passiert, bzw. was mache ich falsch?
Gruß Ulli

8
Nachdem mein Tablet ein Update auf Android 5.0 bekommen hat, wollte ich nachfolgendes nachvollziehen, bin aber bisher gescheitert.

*******************
Changes in Android 5.0

Android 5.0 partially loosens strict permissions of applications writing on SD cards. After a week of extensive work we managed to enable storing vector maps, SRTM data and backups on SD card. All other Locus folders must remain in the internal memory, it is not possible to run them on SD card without issues.

Works since Locus Map 3.11.0

If you have a device with SD card and want to save some storage space, follow these instructions:

go to Menu > Settings > Miscellaneous > Default directories
set new location of Locus/mapsVector, Locus/backup and Locus/data/srtm directories on SD card
restart Locus Map
*****************

Hinweis: Bisher nutzte ich die Methode des Hinzufügens eines Verzeichnisses für Offline-Karten auf der ext. SD und habe den gesamten Rest im Programmverzeichnis belassen, wie für KitKat beschrieben, das funktionierte. Meine Locus-Version ist 3.12.2.

Nun meine Fragen:

Sind die 3 Verzeichnisnamen auf der ext. SD beliebig?

Dürfen sie in einem Unterverzeichnis stehen und müssen wie auf der int. SD mit /Locus beginnen, oder muss es ein anderer Name, z.B. /_LOCUS sein oder müssen sie sogar in der Root der ext. SD stehen?

Dürfen die Verzeichnisse zuerst mit einem Dateimanager erzeugt werden um sie anschließlich in Locus zuzuweisen oder müssen sie in Locus erzeugt werden?

Müssen alle 3 Verzeichnisse auf der ext. Karte stehen oder darf z.B. auch nur mapsVector und backup dort stehen. Hintergrund dieser Frage ist, dass es nach dem anschließenden Kopieren des Inhalts von SRTM data außerhalb Locus beim Neustart von Locus jede Menge Fehlermeldungen gab. Allerdings habe ich die 3 Verzeichnisse innerhalb Locus direkt in der Root der ext. Karte angelegt, was zweifelsfrei unschön ist.

Kann mir jemand helfen?
Gruß, Ulli

9
[DE] - deutschsprachiger Forumsbereich / Re: Locus (pro) Widget
« on: July 06, 2015, 15:18:38 »
Es wurde bereits geschraubt.
Mal die nächste (Test)Version abwarten

Mit dem Update auf 3.10.X scheinen nach einem ersten Test die beiden Probleme
  • Widget repräsentiert nicht den App-Status
  • Widget wird nach Neustart oder event. auch nach längerer Ruhezeit inaktiv
gelöst zu sein.
Interesssant war es gerade beim Neustart: Ich habe nicht sofort nach dem Status des Widgets geschaut. Als ich nach ein paar Sekunden nachschaute war das Widget inaktiv und wurde nach wenigen weiteren Sekunden aktiv und zwar gerade als eine Sofortbenachrichtigung einer anderen App einlief. Ich vermute, dass war auch der Grund für das Problem, nämlich dass in der Initialierungsphase des Smartphones zuviel hin- und hergeht.
Danke! für die Lösung!!
Grüße Ulli

10
[DE] - deutschsprachiger Forumsbereich / Re: Locus (pro) Widget
« on: June 26, 2015, 11:42:57 »
Außer wir finden hier ein eindeutig reproduzierbares Fehlververhalten.
Eindeutig ist, dass das Widget nicht einen aus der App heraus gestarrten Record-Zustand repräsentiert (siehe meinen Beitrag weiter oben). Gestern habe ich einen Record aus dem Widget heraus gestartet und mit Stopp beendet und gespeichert. Das ging klaglos, das Widget war bereit, einen neuen Record zu starten, so wie es sein soll. Heute morgen war das Widget trotzdem tot, obwohl das Smartphone die Nacht über im Standby-Zustand war. Darauf habe ich das Smartphone neu gestartet, um zu sehen, wie das Widget danach aussieht. Interessanterweise war es für ein paar Sekunden OK und wechselte danach wieder dauerhaft ihn den Tot-Modus (Record- und Pausetaste aktiv aber wirkungslos). Diesen Fall konnte ich jetzt schon mehrfach nachstellen.
Gruß
Ulli

11
[DE] - deutschsprachiger Forumsbereich / Re: Locus (pro) Widget
« on: June 23, 2015, 17:30:38 »
Jetzt sollte man nur noch herausfinden wie man diesen Fehler nachstellen kann, damit man draus auch einen Fehlerreport schnitzen kann. Vielleicht fällt Dir in den nächsten Tagen ja ein bestimmter Zusammenhang auf...
OK, gynta, ich bleibe daran. Bis jetzt habe ich nur einen ganz vagen Verdacht, nämlich dass der Fehler dann auftritt, wenn für längere Zeit kein GPS gefixt war. Dann erholt sich das Widget u.U. auch dann nicht, wenn mittlerweile GPS wieder gefixt ist. In der Locus-App selbst lässt sich Record immer starten. Im Fehlerfall geht kein einziger Button, auch der auf die Aufzeichnungseinstellungen (Zahnrad) nicht und auch nicht der Launch der Locus-App aus dem Widget heraus.

edit
Was ich schon sagen kann, ist dass das Widget nicht unbedingt die Verhältnisse der Locus-App wiedergibt, d.h. wenn ich Locus normal starte und die Aufzeichnung aus der App heraus und nicht über das Widget starte und mit der Starttaste das Desktop anzeige, ist das Widget im Ruhezustand. Tippe ich dann auf Record, wird die Aufzeichnung gestoppt.
Umgekehrt sehe ich die Aufzeichnung in der App, wenn ich sie über das Locus-Icon im Widget starte.

Gruß
Ulli

12
[DE] - deutschsprachiger Forumsbereich / Locus (pro) Widget
« on: June 23, 2015, 16:29:13 »
Hallo miteinander,
in der aktuellen Version fällt mir auf, dass das Widget (4x1) nicht immer bereit ist, d.h. nichts passiert, wenn ich auf ein Icon tippe. Man sieht das optisch am Widget gleich daran, dass im Ruhezustand sowohl Start als auch Pause aktiv sind. Wenn es funktioniert, ist im Ruhezustand Pause ausgegraut, Start grün und außerdem steht bei der Entfernung und bei der Zeit jeweils 0. Ich habe festgestellt, dass das Widget beim Entfernen und sofortigem Neuanlegen wieder funktioniert.
Was kann der Grund für dieses Verhalten sein? Ob das auch schon früher so war, weiß ich nicht, da ich das Widget erst jetzt öfters nutze. Möglicherweise passiert es auch nur dann, wenn man zuvor die Locus-App am Laufen hatte.

widget-OK | widget-notOK.


Gruß
Ulli

13
Navigation & Guidance / Re: Automatic Display activation
« on: April 27, 2015, 11:26:16 »
please take care to reverse arrow direction for reverse guidance.
Perfect!
Greetings
Ulli

14
Navigation & Guidance / Re: Automatic Display activation
« on: April 27, 2015, 10:28:16 »
Question: color of tracks during guidance
What you expect?
Here my opinion to all suggestions
- keep original color - will be clear which track is active?
For me this would be fine, because I follow only 1 track at a time and disable other tracks.
- use color of folder? - why this, does it make a sense?
For me OK, see above.
- use color from settings > misc - current approach
In my opinion not logical, because it deals with imported tracks
- use color from settings > guidance - probably most logical right?
My favourite but please with an option to set a line style - see my previous message.
- any other more logical idea?
Not at the moment.
Greetings
Ulli

15
Navigation & Guidance / Re: Automatic Display activation
« on: April 27, 2015, 09:38:41 »
Question: color of tracks during guidance
- use color from settings > guidance - probably most logical right?
That's it, because the color of the guided track belongs to guidance.
But it would be great, if the line style might also be set in this context to have a possibilty to indicate the direction (e.g. any arrow style, because is often difficult to read the display of the smartphone in light surroundings quickly.
Greetings
Ulli

Pages: [1] 2 3