Locus Map - forum

Support => Troubles & Questions => Topic started by: svartbjorn on August 06, 2011, 08:18:13

Title: Zoom Lock shouldn't zoom when enabled
Post by: svartbjorn on August 06, 2011, 08:18:13
The function of the Zoom Lock button changed several versions ago. I tried to get used to it, but found the previous functionality better.

It was like this before:
- when enabled, it locked the existing map AT THE CURRENT ZOOM LEVEL. From now on you could zoom in further by pixel multiplication starting at the current zoom level using the zoom buttons

It is like this now:
- when enabled, it locks the existing map, BUT CHANGES THE ZOOM LEVEL with the same amount as last time used. You have to use the zoom buttons to zoom back out to see the zoom level you were at when enabled. I do not think that is the intention of the Zoom Lock button. The button info says: "This may be useful if you do not have a particular zoom level and still wish to zoom in". So when enabled, it should only lock, not zoom at the same time.

Is this new way of operating your intention, Menion, or is this a bug? I liked the old way much better. Now the zoom may suddenly jump several levels at the moment you enable the Zoom Lock button, depending upon last time used.
Title: Re: Zoom Lock shouldn't zoom when enabled
Post by: menion on August 06, 2011, 08:36:24
nono it's not a bug, it was discussed with berkley before cca month and I find this way more usable so I changed ... viewtopic.php?f=13&t=714&p=3895#p3895 (http://forum.asamm.cz/viewtopic.php?f=13&t=714&p=3895#p3895) ... we can discuss about it. It mainly depend on number of people who like this or that solution ...
Title: Re: Zoom Lock shouldn't zoom when enabled
Post by: svartbjorn on August 06, 2011, 11:05:30
Ok, if that is how most people like it.

I see from the link that people found it annoying the way it was.
I actually find it very annoying the way it is now, since the zoom may jump out when Zoom Lock is enabled, while you actually want to zoom in, and sometimes the zoom in jump is far too much with only some large pixel points.

May I suggest this user selectable in the Map Setting. Something like: "Remember zoom lock" enable/disable
Title: Re: Zoom Lock shouldn't zoom when enabled
Post by: menion on August 06, 2011, 11:32:07
ok, no problem, settings added ...
Title: Re: Zoom Lock shouldn't zoom when enabled
Post by: svartbjorn on August 06, 2011, 11:52:10
Great! What a fast response from you, Menion!

According to Einstein, the speed of light is the fastest speed possible in the universe. But he didn't know about you, Menion - you move faster!!!

Thanks a lot!!
Title: Re: Zoom Lock shouldn't zoom when enabled
Post by: menion on August 06, 2011, 12:15:46
don't be funny and enjoy zoom lock ;)