Locus Map - forum

Development => Versions => Locus Classic (LM Free, LM Pro) => Topic started by: Menion on July 14, 2020, 13:30:23

Title: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Menion on July 14, 2020, 13:30:23
Important links
- list of news (https://help.locusmap.eu/announcement/version-3-47-7-7-2020) of public versions

Versions
7. 7. 2020 - Locus 3.47.0
14. 7. 2020 - Locus 3.47.1
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: balloni55 on July 15, 2020, 14:18:42
Quote
fix: incorrect thumbnails of attached photos
sorry, not for me

my example photos inside zip of post
https://forum.locusmap.eu/index.php?topic=6817.msg60443#msg60443

i have seen that in the exif data of the image that is not displayed as a thumbnail, there is no exif "orientation" (Right top) for "Thumbnail"
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Menion on July 16, 2020, 13:51:04
Hi @balloni55,
thanks for the report. I've received one incorrect photo from John which I was able to solve by updating Picasso library (the library I use for loading images) to a new version. Unfortunately seems it does not solve the issue with your huge photo. Once I've reduced it's size, it works correctly, so it looks like image lib has some problems with bigger photos, damn.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: tapio on July 20, 2020, 16:11:28
BUG
Data Manager - Import tracks into folder - Longtap a gpx - "..." Select All

It selects none.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Henk van der Spek on July 28, 2020, 17:58:05
In 3.47.2 with backups on my external SD-card and Locus completely in internal memory, deleting a backup-zip-file does not work.
I go to "Restore" and tap the three dots and choose delete, but the file is still there.
Minor problem, only used for extra temporarily settings backups.
Android 7.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Čelda on August 17, 2020, 23:54:33
As a geocacher I've been using guidance and notification of points for ages (and it's been working like a charm.). I use a single alert with 3 beeps and alert distance of 50m. However, today I spotted a weird behaviour: Sometimes (but not always) when I started a new guidance to a distant geocache wpt, the alert with beeps came immediatelly even though the distance of the wpt was much bigger than 50m ! Later, when I really reached the distance of 50m no other alert was activated. Locus 3.47.2
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Henk van der Spek on August 18, 2020, 07:12:08
For me the beeps sometimes come before the guidance calculation is finished at the startup of the guidance. I see Locus then searching for the nearest point.

Verstuurd vanaf mijn Armor_2 met Tapatalk

Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Menion on August 31, 2020, 16:13:06
Hi guys,
sorry for my missing answers here. Is the problem with guidance notification still actual? Should I check it more carefully or it was a one-time issue.

The new version already published, so please new bugs/discussion regards the new version in the appropriate topic here (https://forum.locusmap.eu/index.php?topic=7100.new), thanks.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Čelda on August 31, 2020, 16:23:50
In the meantime I've found out more exactly when the problem occurs:
The wrong alert comes when I guide to a wpt (a geocache), reach it and start a new guidance to another wpt without stopping the old one first. When I stop the old one first and then start the new guidance, everything works OK.
However, in the new Locus version this might have been corrected, I will give another report if not.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Menion on September 01, 2020, 10:39:18
Weird. I'm trying to simulate it and no problem. Even in code, it looks safe. Every activated guidance has fresh new parameters so such a problem should not appear. I'll be watching this.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: michaelbechtold on September 01, 2020, 12:40:35
Hi Menion,
after some time I used the routing/guidance again and found that the screen does no longer turn on when voice command comes. Locus has admin rights, and the setting is enabled.

Also, on the S10 the icon selection for points is flickering like crazy, the lower bound of the overlay window. Same with screen selection of points in the routing setup, there the whole map is flickering.

Saving a track requires turning the device horizontally to get to the save button - again on the S10.

But there is good news, too: once the location is switched off inside Locus, the Android level GPS tracking goes passive, too (since a few weeks already, to be honest :-)

TXs and cheers
Michael

PS: above applies to the new alpha, too.

Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: Menion on September 01, 2020, 20:31:26
Hello Michael,

thanks for precise description of interesting issues ... well, my colleague Jan has S10 as well and he does not suffer by a problems you wrote.

Interesting ... restart of device does not help? What about disabling full-screen (it also sometimes affect more than expected)?

GPS fine ... anyway weird things happens on your device :/.
Title: Re: [APP] - version 3.47.+ ( 7. 7. 2020 )
Post by: michaelbechtold on September 05, 2020, 22:41:26
Hi Menion,
restart does not help, unfortunately.
However, disabling full screen mode brings back the save botton.
Yet, there is a reason to use full screen mode ...
Can this issue be fixed ?
Any logs you would need ?
TXs and cheers
Michael