Locus Map - forum

Support => Troubles & Questions => Topic started by: alanmcd on November 09, 2019, 23:30:11

Title: Points - Photo Attachment - No apps available message
Post by: alanmcd on November 09, 2019, 23:30:11
I've searched here but can't see anyone with this issue.
Not sure when this started - version-wise. I am running v3.41.0
When I try to view a photo attachment of a point, that I took, the .jpg file is listed but when I tap it, I get the orange box message 'No apps available' at the bottom of the screen.
I have made sure Gallery is the default app for .jpg files. I've restarted the phone (to make sure). I cannot see where, in Locus, I set the default app for photos/jpg files (If there is such a setting)
The thumbnail is visible on the map and on the Points BASIC INFO tab but the thumbnail icon under "PHOTOS" is a grey generic icon. The filename is correct. The path where the actual photo is stored is /SD Card/DCIM/Camera but Locus only shows the filename.
Is there a setting I need to adjust?
thanks
Title: Re: Points - Photo Attachment - No apps available message
Post by: menion on November 10, 2019, 15:17:46
Hi, does it happen for all the photos? Also for a new added? Maybe a path is no longer valid, the file was renamed etc?
Title: Re: Points - Photo Attachment - No apps available message
Post by: alanmcd on November 10, 2019, 21:14:17
Yes - if I add an attachment (i.e. the same photo) then delete the old attachment, it works as designed. So it must be a changed path. Shame, a lot of work now to put them all back.
Alan
Title: Re: Points - Photo Attachment - No apps available message
Post by: menion on November 10, 2019, 21:32:57
Hmm is it somehow possible to detect how the path has changed? App already do some "auto-fix", so some changes in internal structure are able to fix automatically, so maybe, if both paths will be similar, I may improve it as well.