Locus Map - forum

Support => Troubles & Questions => Topic started by: silvermapper on July 08, 2017, 22:37:50

Title: Map tiles "Loading..."
Post by: silvermapper on July 08, 2017, 22:37:50
I feel distressed!  I have used Locus Map for more than two years with barely a fault.  I was walking on Thursday when my GB map showed map tiles loading, suddenly.  I did not know what caused it but thought it was a blip of some sort because I have not once had such an issue.  Now at home, the same situation is continuous.  I can zoom out (13) and the whole screen displays, but slowly.  Zooming in (from 14) or panning, a map tile is either frozen or a number of map tiles display, "Loading..." but nothing happens.  My set up and content has not changed, essentially.  Nevertheless, I have deleted all folders containing my specific tracks and boundaries; I run CCleaner every day; I have tried another mapping dataset; powered off and on my 'phone; cleared the cache in Settings/Apps.  I have been aware recently, too, that Locus Map is taking much longer to load upon startup.
I understand this might not be a Locus Map problem as such, but this forum has such experts, I wonder if someone might be able to help.
Title: Re: Map tiles "Loading..."
Post by: lor74cas on July 09, 2017, 08:13:55
With the last version all users found a quick cold start up did you update it?
If you store maps on the sd and this became corrupted can slow down the app.
You wrote about use of clcceaner, clearing apps cache etc this sounds me you have poor memory resources.
Poor memory resources and a corrupted sd are the ingredients of the recipe that locked my phone some months ago.

Inviato dal mio SM-G800F utilizzando Tapatalk

Title: Re: Map tiles "Loading..."
Post by: silvermapper on July 09, 2017, 09:09:21
I thank you for your reply.
1. I updated Locus Map one month ago.  I updated it again yesterday evening in hope but it made no difference.
2. I  use maps loaded on internal storage always.  I have two country maps stored on my SD card as backup only;
3. I use CCleaner as a matter of course - it follows what I do on my desktop - not because of any poor memory resources.  For anyone's information: I have 8GB internal storage, of which 5.52GB is available to use, but 3.5GB is used currently.  I am informed I have 851MB Ram of which no more than 500-600MB is ever used.  I should re-iterate this has been standard for a long time and not caused any difficulties previously.
Title: Re: Map tiles "Loading..."
Post by: Menion on July 09, 2017, 10:18:26
hmm not sure where may be a problem, but I may as a first step suggest to simply rename main "Locus" directory in your internal memory to something "Locus backup" ( maybe you should backup this directory into your computer just for sure ) and then try start Locus Map. It should then create a completely new empty directory "Locus", so you will see if problem is in some data in old directory.

Step by step ... so if all will work fine with online maps for example, you may try to copy content from old directory to new, firstly maps ( from "maps" and "mapsVector" directories ), later content of Locus/data/ directory. Not sure how to help more here ... hmm also suggest to check your SD card directly in PC by any tool that is able to recognize corrupted SD card.
Title: Re: Map tiles "Loading..."
Post by: silvermapper on July 09, 2017, 17:23:52
Hurrah! for Menion - well done!
I followed your steps.  The map that appeared zoomed properly.  I loaded my own GB map and that worked, too.  The issue appears to have involved Voluntary UK map theme (nothing to do with your excellent theme, itself, John!) and coincides with my walk on Thursday, which is why it makes sense: I have created, and used before, my own .png files for barriers because they display more clearly when walking.  I decided to add these to vol_res/svg before my walk.  It seems that what I did caused this subsequent problem.  All is well once more.
Many thanks, Menion.
Title: Re: Map tiles "Loading..."
Post by: Menion on July 09, 2017, 17:34:31
Ahh perfect. Hmm I noticed similar issues before ... problem is that in case, there is an issue in images in vector themes, instead of display of some error message, Locus Map tries to load invalid images again and again and ... and here is a result.
Title: Re: Map tiles "Loading..."
Post by: john_percy on July 09, 2017, 18:52:21
@silvermapper The images used for the voluntary theme are SVG not PNG. That's where the problem lay. Either edit the theme to reference your PNG files or upload SVG files instead.

Sent from my XT1039 using Tapatalk

Title: Re: Map tiles "Loading..."
Post by: silvermapper on July 10, 2017, 10:25:27
I thank you for your comment.  I have two questions:
1. I count seven .png files existing already in your February 2017 Voluntary Locus\_themes\vol_res\svg folder: gate_nobike.png, for example.  I am unsure following your comment whether they should be there or what allows them to be there, considering it was my inclusion of .png files that caused the problem last week.
2. I would not know how edit the theme to reference .png files.  I used to convert them to .svg.  Opening in, they are 500x500 pixels.  I created them as 42x42 pixels.  I have no knowledge of .svg, apart from it being vector not raster, and what size is necessary for my images to work appropriately.  I should appreciate what assistance you can provide.
Title: Re: Map tiles "Loading..."
Post by: john_percy on July 10, 2017, 14:10:49
The PNG files in my SVG folder are left over images from the key to the theme. They have no effect.
I wonder if you deleted an SVG file that was needed.
The images are scaled in the theme, so their size is immaterial. However Locus used to be highly sensitive to what SVG files it would display. I edit mine in Inkscape and then run them through SVGcleaner.
The theme is plain text XML. You can open it in notepad or similar on a PC, search for the name of the file you want to replace and change the name.

Sent from my XT1039 using Tapatalk

Title: Re: Map tiles "Loading..."
Post by: silvermapper on July 10, 2017, 15:36:53
I thank you for your thought and explanation.  I should consider the limits of my knowledge more, but I have learnt a lot over time, equally.
Title: Re: Map tiles "Loading..."
Post by: john_percy on July 10, 2017, 20:15:53
We all do.

Sent from my XT1039 using Tapatalk