Locus Map - forum

Support => [DE] - deutschsprachiger Forumsbereich => Topic started by: bezel on March 04, 2017, 08:39:42

Title: LoMaps und Elevate Theme - funktioniert nicht?
Post by: bezel on March 04, 2017, 08:39:42
Hallo!

Testweise habe ich mir nun doch auch einmal eine LocusMap (LoMaps) heruntergeladen, muss aber leider feststellen, dass ich diese nur mit den internen Themes verwenden kann, bei der Verwendung zB mit dem externen Elevate werden mir zB Fahrrad- oder Wanderrouten nicht angezeigt.

Gibt es doch eine Möglichkeit, Elevate in vollem Umfang mit den LoMaps zu nutzen?
Oder was mache ich falsch (gibt es eine besondere notwendige Einstellung)?

Ich dank' Euch vielmals für Eure Hinweise!
Grüße
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 04, 2017, 12:15:15
Das Thema Wanderrouten ist m. E. in den LoMaps  besser gelöst, weil es mehrere Klassen (internationale, nationale, regionale Routen) auf dem selben Weg gleichzeitig darstellt. Bei den Openandromaps "sticht" die höhere Route die niedrigere (also international vor national etc.). Möchte man einem lokalen Wanderweg folgen, auf dem auch eine höhere Wanderroute liegt, kann man das bei den Openandromaps  nicht erkennen.
Elevate ist m. W. eher auf die Openandromaps abgestimmt und würde deshalb für die LoMaps einige Anpassungen erfordern.
Ich habe das so gelöst, dass ich für die Lomaps in meinem Theme eine eigene Sektion eingebaut habe. Allerdings muss ich dann das Theme auch switchen, von Wandern mit Openandromaps auf Wandern mit einer LoMap.

==> mal eben, ist nicht.  :D
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: bezel on March 04, 2017, 13:24:46
Bei Wanderwegen magst Du recht haben, insbesondere in Kombination mit dem HiLo-theme ( http://forum.locusmap.eu/index.php?topic=4982.0 (http://forum.locusmap.eu/index.php?topic=4982.0) ).
Ein Vergleich hier:
(https://s21.postimg.org/y6qmvbayr/oam_lomaps_WANDERN_vergleich_FORUM.jpg) (https://postimg.org/image/y6qmvbayr/)  von links nach rechts:
screenshot 1: openandromaps + elevate theme "Wandern"
screenshot 2: openandromaps + HiLo theme (Wandern)
screenshot 3: LoMaps + internes theme "Wandern + Rad" (aber ohne Rad-und MTB-Routen; nur Wanderrouten)
screenshot 4: LoMaps + HiLo theme (Wandern)


Wenn man sich allerdings gezielt nach MTB-Routen anzeigen lassen will, siehts wieder völlig anders aus. LoMaps mit seinem internen "Wandern+Radfahren" theme überzeugt hier - was Anzeigedeutlichkeit und Genauigkeit (viele Strecken fehlen) - überhaupt nicht:
(https://s16.postimg.org/d97telcqp/oam_lomaps_MTB_vergleich_FORUM.jpg) (https://postimg.org/image/d97telcqp/)  von links nach rechts:
screenshot 1: openandromaps + elevate theme "Mountainbike"
screenshot 2: LoMaps + internes theme "Wandern+Radfahren" (ohne Anzeige der Radwege)

Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 04, 2017, 13:46:06
Fürs Radfahren sind die Openandromaps besser geeignet.
Aber ich hatte verstanden, dass Du das Elevate Theme für die LoMaps, auch zum Wandern, nutzen willst. Das geht nur mit entsprechendem Aufwand.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: bezel on March 04, 2017, 19:09:43
Sowohl LoMaps, als auch openandromaps (OAM) zu verwenden, benötigt leider doch viel Speicherplatz.

Das ist ja das Problem - LoMaps sind einwandfrei im "Wanderbereich", gerade, wie ich finde, in Zusammenspiel mit dem HiLo-theme.
Bei Rad/MTB-Touren sieht es leider schlecht aus, da hier das Elevate-Theme nur in Kombination mit OAM wirklich gut dargestellt wird, gerade im höheren Zoom-Bereich, aber eben nicht mit den LoMaps.
LoMaps scheint mir nicht komplett "ausgedacht" zu sein - wo ja noch zusätzliche Kosten anfallen, die sich bei einer Europa-Abdeckung ganz schön summieren...
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 05, 2017, 15:21:51
Wenn man sich allerdings gezielt nach MTB-Routen anzeigen lassen will, siehts wieder völlig anders aus. LoMaps mit seinem internen "Wandern+Radfahren" theme überzeugt hier - was Anzeigedeutlichkeit und Genauigkeit (viele Strecken fehlen) - überhaupt nicht:
(https://s16.postimg.org/d97telcqp/oam_lomaps_MTB_vergleich_FORUM.jpg) (https://postimg.org/image/d97telcqp/)  von links nach rechts:
screenshot 1: openandromaps + elevate theme "Mountainbike"
screenshot 2: LoMaps + internes theme "Wandern+Radfahren" (ohne Anzeige der Radwege)

Hier bin ich mir dabei allerdings nicht sicher, ob das Elevate Theme zeigt, was Du als MTB-Routen identifizierst.
M. E. sind da keine Mountainbike-Routen, sonder nur Wanderwege.
Hier mal die Ansicht in JOSM mit der Cyclemap:
(https://s14.postimg.org/loym7s4ul/Josm_Schlossberg_Cyclemap.jpg) (https://postimg.org/image/loym7s4ul/)
Ich habe auf der germany_south außerdem die Wanderwege eingeblendet (Wandern und Radfahren internen Theme)
(https://s27.postimg.org/ttcz9alkv/Screenshot_20170305_150953.png) (https://postimg.org/image/ttcz9alkv/)
Vielleicht kann Tobias Licht ins Dunkel bringen?


Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: bezel on March 05, 2017, 18:25:48
Ich weiß nicht, was die Parameter dafür sind, dass eine bestimmte Strecke als MTB-, aber auch als Radstrecke gilt und damit auch angezeigt wird.
Auch, wenn ich mir nur die Radstrecken anzeigen lasse, ergeben sich andere, bzw. bei LoMaps "fehlende" gekennzeichneten Strecken, siehe hier:

(https://s23.postimg.org/z9pxuqeef/oam_lomaps_RAD2_vergleich_FORUM.jpg) (https://postimg.org/image/z9pxuqeef/)  von links nach rechts:
screenshot 1: OAM + Elevate 'Radfahren'
screenshot 2: LoMaps + Elevate 'Radfahren'
screenshot 3: LoMaps + internes theme 'Wandern und Radfahren' (nur Radwege aktiviert)
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jajaballard on March 06, 2017, 08:52:50
Was hier (Reply #2) dargestellt wir sind keine MTB -Routen sondern Tracks die in OSM mit einem MTB-Schwierigkeitswert belegt sind. (mtb:scale). Diese werde in dem Theme Mountainbike von Elevate ausgewertet und Frablich unterschiedlich dargestellt.
Details unter: http://www.openandromaps.org/kartenlegende/elevation-hike-theme (http://www.openandromaps.org/kartenlegende/elevation-hike-theme)
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 06, 2017, 09:44:26
Was hier (Reply #2) dargestellt wir sind keine MTB -Routen sondern Tracks die in OSM mit einem MTB-Schwierigkeitswert belegt sind. (mtb:scale). Diese werde in dem Theme Mountainbike von Elevate ausgewertet und Frablich unterschiedlich dargestellt.

Vielen Dank, so etwas hatte ich mir schon gedacht. Wenn das, wie ich weiter vermute "mtb:scale=0" ist, kann man sich die farbliche Markierung auch sparen. Insofern sehe ich in den LoMaps, bzw. desssen Themes auch noch keinen Nachteil.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: Tobias on March 06, 2017, 11:23:48
Elevate funktioniert nur mit OAM richtig, für LoMaps ist es nicht gemacht. Macht für mich auch wenig Sinn, dass dafür auch noch anzupassen, da in LoMaps viele Eigenschaften fehlen, die Elevate/OAM ausmachen, noch dazu da LoMaps etwas kosten.
mtb:scale=0 anzuzeigen macht durchaus Sinn, da es ja auch sein kann, dass gar nichts getagged ist. So ist man auf der sicheren Seite. Jedoch kann das bei highway=track überhand nehmen, deshalb lässt sich auch die Anzeige für tracks etc. abschalten.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 06, 2017, 15:34:17
Das kann ich nachvollziehen. Hier scheint der TO aber "mtb:scale=0" mit  MTB-Routen zu verwechseln und zu dem Schluß zu kommen, dass die Routen nicht in den LoMaps enthalten sind.
Wie man´s macht macht man´s falsch.  ;D
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: Tobias on March 06, 2017, 21:57:28
Hier scheint der TO aber "mtb:scale=0" mit  MTB-Routen zu verwechseln und zu dem Schluß zu kommen, dass die Routen nicht in den LoMaps enthalten sind.
Wie man´s macht macht man´s falsch.  ;D
Scheint so 8)

Aber eigentlich ist ja fast Absicht dahinter, für mich sind Routen zweitrangig. Wichtiger ist mir, die Eigenschaften der eigentlichen Wege gut zu erkennen, und mir damit selber Touren zusammen zu stellen. Wenn jemand also einen Weg mit "mtb:scale=0" bewertet hat, ist da die Aussagekraft eigentlich höher für die Eignung als irgendwelche ausgeschilderten Routen. Auch wenn das für manche schon eher vom Anspruch her langweilig ist ;-)
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: bezel on March 07, 2017, 08:16:44
Danke für Eure Meldungen - wenn ich damit auch nicht so ganz richtig schlau geworden bin... Kenne mich, was die techn. Seite betrifft, nicht aus - von daher sagt mir das erwähnte script "mtb:scale=0"  nichts.
Was bedeutet dies, wenn es auf "0", wenn auf "1" gesetzt ist? (zu finden im script des elevate themes?)

Seltsam auch, das die Bewertung von reinen "Radwegen" bei den zwei Karten und Themen unterschiedlich ausfällt.. Bei dem einen werden Straßen als "Radweg" gekennzeichnet, beim anderen nicht.
(siehe auch oben)
(https://s23.postimg.org/z9pxuqeef/oam_lomaps_RAD2_vergleich_FORUM.jpg) (https://postimg.org/image/z9pxuqeef/)
screenshot 1: OAM + Elevate 'Radfahren'
screenshot 2: LoMaps + Elevate 'Radfahren'
screenshot 3: LoMaps + internes theme 'Wandern und Radfahren' (nur Radwege aktiviert)
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 07, 2017, 08:18:23
Quote
Aber eigentlich ist ja fast Absicht dahinter, für mich sind Routen zweitrangig. Wichtiger ist mir, die Eigenschaften der eigentlichen Wege gut zu erkennen, und mir damit selber Touren zusammen zu stellen. Wenn jemand also einen Weg mit "mtb:scale=0" bewertet hat, ist da die Aussagekraft eigentlich höher für die Eignung als irgendwelche ausgeschilderten Routen. Auch wenn das für manche schon eher vom Anspruch her langweilig ist ;-)
Kann man denn davon ausgehen, dass Mountainbiken, auf nicht speziell ausgeschilderten Routen, erlaubt ist, wenn  "mtb:scale=X"  getaggt wurde? In manchen Bundesländern ist m. W. das Radfahren auf "schmalen" Waldwegen nicht gestattet. Dass der Weg ev. trotzdem geeignet ist, kann natürlich sein.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: balloni55 on March 07, 2017, 08:25:38
Quote
In manchen Bundesländern ist m. W. das Radfahren auf "schmalen" Waldwegen nicht gestattet
stimmt, in Badenwürttemberg dürfen nur Waldwege mit einer Breite von mindestens 2 Metern mit dem Mountainbike befahren werden :P
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: ManfredG on March 07, 2017, 08:56:26
Hallo bezel, schau doch einfach mal auf https://taginfo.openstreetmap.org/ . Geb dort z.B. nur mal mtb ein. Klickst Du dann auf mtb:scale (388807 Einträge) gibt es auch die Möglichkeit, deutsche Beschreibungen / Wiki anzuzeigen. Habe vor Jahren von einem sehr hilfsbereiten Tobias diesen Hinweis bekommen, und damit hat er mir wirklich sehr geholfen!  '0 beschreibt einen Weg, welcher keine besonderen Schwierigkeiten aufweist.'

Das interne Locus-Theme bezeichnet Radrouten als Radwege, bzw. Wanderrouten als Wanderwege.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 07, 2017, 13:50:03
Auf Taginfo muss man aber auch erstmal draufkommen.

Das Problem entsteht vorher, weshalb ich auch nicht unbedingt derselben Meinung wie Tobias bin, dass man "0" unbedingt besonders ausweisen müsse.

Zunächst sieht man auf einer Karte "blaue" Linien. Sind das nun besondere Radwege oder Radrouten? Zumindest könnte man das aus der Legende unter http://www.openandromaps.org/kartenlegende/elevation-hike-theme ablesen.
Gleichzeitig sind: "S0: Blaue Balken auf Wegen heißt kein besonderes fahrtechnisches Können nötig". Außerdem sind blaue Balken an blauen Linien noch "Uphill"-Kennzeichnungen.

Da ich selber "blau" für ausgewiesene Radwege verwende, finde ich persönlich das verwirrend, zumal scale und uphill jeweils "0" (Null) sind, also zumindest für mich keinen Zusatznutzen darstellen.
Die Nachbarwege, ohne diese spezielle Kennzeichnung, sind dann auch "braun", unterscheiden sich in Natura aber vermutlich nicht von den "blauen" Wegen.
Also immer schön die Legende lesen  8)
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: Tobias on March 07, 2017, 19:43:09
Kann man denn davon ausgehen, dass Mountainbiken, auf nicht speziell ausgeschilderten Routen, erlaubt ist, wenn  "mtb:scale=X"  getaggt wurde? In manchen Bundesländern ist m. W. das Radfahren auf "schmalen" Waldwegen nicht gestattet. Dass der Weg ev. trotzdem geeignet ist, kann natürlich sein.
Wenn Radfahren verboten ist (mittels bicycle=no), wird mtb:scale nicht angezeigt. Das geht davon aus, dass Radfahren auf tracks und path grundsätzlich erlaubt ist, das ist aber nicht in jedem Land so. Bei OpenStreetMap ist das je nach Land verschieden:
http://wiki.openstreetmap.org/wiki/OSM_tags_for_routing/Access-Restrictions
In Deutschland aber trifft das zu, d.h. in BW müssten alle Wege, auf denen Radfahren verboten ist, mit bicycle=no markiert sein.

Auf Taginfo muss man aber auch erstmal draufkommen.
Eigentlich reicht die Elevate Legende, da ist einerseits alles kurz beschrieben, andererseits wird auf http://wiki.openstreetmap.org/wiki/DE:Key:mtb:scale verlinkt.

Das Blau kommt übrigens von der Singletrail-Skala, auf der MTB-Scale beruht:
http://www.singletrail-skala.de/s0
Daher macht es wenig Sinn, hier andere Farben zu verwenden. Und da die Darstellung in Elevate von Routen und Pfaden sich sehr deutlich unterscheidet, ist auch wenig Verwechslungsgefahr gegeben.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: jusc on March 08, 2017, 12:45:47
Das Blau kommt übrigens von der Singletrail-Skala, auf der MTB-Scale beruht:
http://www.singletrail-skala.de/s0
ach so, die  Singletrail-Skala hat aber gerade mal drei Farben für fünf  Schwierigkeitsgrade. Damit kann man imho auf Karten, zumal auf einem 4 -5 Zoll Smartphone wenig anfangen.

Vielleicht könnten sich  Moutainbiker mal dazu äußern?
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: Tobias on March 08, 2017, 19:23:53
ach so, die  Singletrail-Skala hat aber gerade mal drei Farben für fünf  Schwierigkeitsgrade. Damit kann man imho auf Karten, zumal auf einem 4 -5 Zoll Smartphone wenig anfangen.
Deshalb wird auch S1 und S3 zweifarbig dargestellt, wie auch auf der Singletrailskala als fließender Übergang.

Das Schema blau-rot-schwarz ist an die Skipisten angelehnt, wie auch die Wanderweg-Einteilung vom DAV (+gelb), also sollte es eigentlich durchaus einleuchtend und verständlich sein.

Von Mountainbikern hab ich da bisher ziemlich positive Rückmeldung. Höchstens, dass sie bei Gegenden mit höherer Wegdichte außerhalb der Alpen (Elevate habe ich auf die Nutzung in den Alpen optimiert) auf die Markierung von Forstwegen verzichten können (insb. S0), deshalb hab ich da optional gemacht.
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: bezel on March 09, 2017, 08:21:01
Hallo bezel, schau doch einfach mal auf https://taginfo.openstreetmap.org/ . Geb dort z.B. nur mal mtb ein. Klickst Du dann auf mtb:scale (388807 Einträge) gibt es auch die Möglichkeit, deutsche Beschreibungen / Wiki anzuzeigen. ...
Danke für den Hinweis, aber ehrlich gesagt, als ziemlicher Laie komme ich damit nicht zurecht - sagt mir nicht sehr viel...
Ich muss aber doch nochmals auf die Kennzeichnung von Radwegen (nicht MTB!) zurückkommen, da das für mich noch nicht so ganz geklärt ist:
warum werden bei der Kombination OAM+Elevate "Radfahren" mehr Straßen als Radwege gekennzeichnet, als unter Lomaps mit Elevate "Radfahren" od. mit internem "Radfahren+Wandern"-theme?
(siehe auch screenshots oben)
Title: Re: LoMaps und Elevate Theme - funktioniert nicht?
Post by: Tobias on March 09, 2017, 19:17:54
warum werden bei der Kombination OAM+Elevate "Radfahren" mehr Straßen als Radwege gekennzeichnet, als unter Lomaps mit Elevate "Radfahren" od. mit internem "Radfahren+Wandern"-theme?
Das liegt an dem von Christian in OAM verwendeten "UCN" Routen und Auswertung von weiteren Markierungen, nicht nur Relationen. Normalerweise werden Fahrradrouten in OpenStreetMap so markiert:
http://wiki.openstreetmap.org/wiki/Fahrradroutentagging_Deutschland

Es gibt aber auch vereinfachte (oder unvollständige) Markierungen:
http://wiki.openstreetmap.org/wiki/Cycle_routes#Tagging_cycle_route_networks
In Deinem Ausschnitt z.B.:
http://www.openstreetmap.org/way/8025861#map=17/47.98345/7.88902&layers=D
Da ist ein lcn=yes vorhanden, das sagt aus, dass das eine lokale Radroute sein soll. Das wird in OAM ausgewertet, in LoMaps nicht.