Locus Map - forum

Development => Versions => Released => Topic started by: menion on February 24, 2012, 10:17:53

Title: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 10:17:53
24.2.2012 - Locus 2.0.0
exactly after a month, new version. Believe all will works fine, anyway bug reports (mainly due to number of news) are expected and welcome!
Title: Re: [APP] - version 2.0.X
Post by: jusc on February 24, 2012, 11:38:04
Hi menion,

I can see only the free version 2.0 in the Market. Correct?
Title: Re: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 11:40:43
no, both are there. Just wait a while. You know, sometimes Market do not work in ways we all want ...
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 24, 2012, 13:57:29
Hi,
after updating from a perfect 1.16.3 to 2.0 Locus pro reacts very slowly, vector map loads after 20 sec: the processor runs at 100 % constantly.
So where can I get the old version?
Title: Re: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 14:24:32
this have to have some good reason. Downgrade to older version is not solution.

Are you using any special feature? The fact that processor run on 100% means that there will be probably just one problem, one running task in Locus. Even if you leave locus for a while, this happen? If so, try to send me log from CatLog please, maybe there will be some error on background or some hint why this happen
Title: Re: [APP] - version 2.0.X
Post by: corbas on February 24, 2012, 14:31:20
Hi, I have downloaded new 2.0 version about 1 hour ago, but the same problem.
On HTC wildfire I use mostly offline / dowloaded/ vector map - slovakia.
On previous version i works well, but now it is very very slow.
To print new area, or zoom on map it takes not 20sec, but i my case about 50-70 sec and during these time is processor on 100%.
Something is wrong...

EDIT: I am sending You catlog file - start record, start locus pro- wait about 3min! for loading vector map-exit locus-stop recording.
It now really takes abou 3min for loadingand show vector map.

St.
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 24, 2012, 14:41:26
Quote from: "menion"
this have to have some good reason. Downgrade to older version is not solution.

Are you using any special feature? The fact that processor run on 100% means that there will be probably just one problem, one running task in Locus. Even if you leave locus for a while, this happen? If so, try to send me log from CatLog please, maybe there will be some error on background or some hint why this happen

Nothing special feature.
Without locus the processor runs at 10-15 %, I never had this before.

When I stop locus the processor goes at once to these lower values.

I donĀ“t know how to use catlog (my phone is rooted).

The last err logs in locuslogs are from 10.02.2012.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 15:00:48
ok, so please when you'll have some time. Install from market program called CatLog. Then start locus and play with it a while. After that close it, run CatLog program and after few secs, when data load, from menu select "save" and send me on locus@asamm.com email with this log. Hope there will be some info because I tested it quite a lot on four devices and no similar problem for a whole time ...
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 24, 2012, 15:25:14
Quote from: "menion"
ok, so please when you'll have some time. Install from market program called CatLog. Then start locus and play with it a while. After that close it, run CatLog program and after few secs, when data load, from menu select "save" and send me on locus@asamm.com email with this log. Hope there will be some info because I tested it quite a lot on four devices and no similar problem for a whole time ...


Done.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 16:02:03
thanks corbas for email. Unfortunately in your log is no important info. Is this happen only with vector maps? Other maps works correctly? (or Blank map). Tramp, mail from you do not come. Maybe post it here on forum? Thanks
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 24, 2012, 16:09:19
Quote from: "menion"
thanks corbas for email. Unfortunately in your log is no important info. Is this happen only with vector maps? Other maps works correctly? (or Blank map). Tramp, mail from you do not come. Maybe post it here on forum? Thanks

I will try it here.
Title: Re: [APP] - version 2.0.X
Post by: corbas on February 24, 2012, 16:20:28
Problem is only with vector maps. I tried online maps, and downloaded maps/OSM,freemap/ It is working well and fast. Switch back to vector map, i need wait very long time - sometimes few minutes to draw a map, when I move on the map, the same - wait 50,100,150 or 200sec. Application is still responding , but there is only very long time for redraw vector map.Problem will be in this new version, because yesterday I used vector maps and worked well.
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 24, 2012, 16:27:17
I have this problem with all maps, not only vector maps (e.g. with own maps generated with MOBAC in sqlitedb-format).

Edit: the sqlitedb maps are loading relative fast but the processor stays at 100 %.

Edit2: with a blank map the processor has 80 %.
Title: Re: [APP] - version 2.0.X
Post by: krzysiekz on February 24, 2012, 18:10:40
On wildfire vector maps are useless now, they are loading very slow.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 18:40:35
thanks for log tramp, but unfortunately no info there. Damn, it's big mystery for me.

I have home one quite old Huywei phone so I'm now trying to install some CM version on it. Hope this will work and also that maps will not work on it. Don't worry guys, I'll fix it for sure :). Anyway as I told, quite mystery. For me all works absolutely without problem and I also do not changed anything in base map system ...
Title: Re: [APP] - version 2.0.X
Post by: Starman on February 24, 2012, 19:37:45
Hi Menion-
Just joined this forum. After updating Locus, I also updated the one vector map I had installed:
sdcard/Locus/mapsvector/americas/united_states/minnesota.osm.map

To troubleshoot, when I move the map to the sdcard directory so that Locus cannot see it, it gets renamed:
sdcard/minnesota.osm

Could the problem be in how the zipping and unzipping handles the double extension?

Also, the big cpu usage for me seems to be my Kaspersky Mobile Security. When I terminate it, Locus function returns to normal
(with the vector map still hidden)

Regards,
Starman
Title: Re: [APP] - version 2.0.X
Post by: menion on February 24, 2012, 20:31:52
Hello Starman, did you know that I even created special topic about you?? viewtopic.php?f=26&t=1530&p=9190 (http://forum.asamm.cz/viewtopic.php?f=26&t=1530&p=9190) (if that was you)

Anyway about issue:
 - I was talking with berkley by icq and he had similar problem few days ago on one testing version. After phone restart, everything fine (also now)
 - no success with Huawei still, anyway I was comparing codes (current with older) and found one small difference. It will probably not solve this issue, but please, try anyone this regular free version 2.0.0.1 and let me know, thanks ...

[s:1fkzq275][attachment=0:1fkzq275]2.0.0.1.apk[/attachment:1fkzq275][/s:1fkzq275]

ah yes, and Starman, I'm not sure if I understand. May you describe issue with file ending better for me? Thanks ...
Title: Re: [APP] - version 2.0.X
Post by: berkley on February 24, 2012, 20:47:21
Just want to add this:

I had the testing version on my phone (SGS2 on 2.3.6). The problems were gone after restart of the device.
But on my tablet (TF101 on 3.2.1) everything worked fine from the beginning!

Cheers
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 24, 2012, 21:17:32
Quote from: "menion"
Hello Starman, did you know that I even created special topic about you?? viewtopic.php?f=26&t=1530&p=9190 (http://forum.asamm.cz/viewtopic.php?f=26&t=1530&p=9190) (if that was you)

Anyway about issue:
 - I was talking with berkley by icq and he had similar problem few days ago on one testing version. After phone restart, everything fine (also now)
 - no success with Huawei still, anyway I was comparing codes (current with older) and found one small difference. It will probably not solve this issue, but please, try anyone this regular free version 2.0.0.1 and let me know, thanks ...

[attachment=0:sfv9q7kn]2.0.0.1.apk[/attachment:sfv9q7kn]


Hi there! I have the same issue on my Huawei U8160 - Vector map that formerly loaded within 5 seconds now needs about 5 minutes! Tried the provided version 2.0.0.1 but the same :-(

Could you somehow provide the old version? I was absolutely happy with it!

Thanks, sukmar
Title: Re: [APP] - version 2.0.X
Post by: Starman on February 24, 2012, 21:22:02
Menion-
Yes, I admit it, I am the same Starman.  :P

Disregard my previous comments about the file extension. On closer examination, my Astro file browser was truncating the file extension.

I keep both Free and Pro versions on my phone so that I can harass  :P  posters for both on the Android Market, and had updated both.
I just tried Free with a vector map, and it seemed normal.

Starman
Title: Re: [APP] - version 2.0.X
Post by: gynta on February 24, 2012, 22:37:34
No problems here with free and pro (on phone and tab).
btw. waiting four weeks was hard :)
Title: Re: [APP] - version 2.0.X
Post by: babi on February 24, 2012, 23:22:22
Hi,
I have the same problem. Locus Pro starts more than forty seconds and doesn't remember map position and zoom from last session! Vector maps are also useless-very long loading time.
Using port of CyanogenMod 7.2, Android 2.3.7

Sent from my HTC Wildfire S using Tapatalk
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 06:31:50
Quote from: "menion"
After phone restart, everything fine (also now)
try anyone this regular free version 2.0.0.1 and let me know, thanks ...

Hi,
after a restart of my SM the processor is again at 100%.
With your beta 2.0.0.1 I have the 100% too (with all map types, even empty maps).

Please give us a download link to the last version.
Title: Re: [APP] - version 2.0.X
Post by: berkley on February 25, 2012, 07:58:50
Tramp,

downgrading isn't a good idea, it may be possible that your databases get destroyed.

You can try this:
- just in case, something goes wrong: backup your settings in the app and backup Locus folder on your device
- uninstall Locus Free & Pro
- restart your device
- install Locus Free & Pro

Good Luck!
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 08:13:18
Huawei is working and same problem on my phone also. Anyway all methods return useless results. So by comparing older codes I changed also one think and it reduces vector maps loading time on U8120 phone from cca 4 minutes to 20 secs. May you suggest me some application that show me processor usage (perfectly in system bar) so I can also check that all is working fine?

Anyway, may someone test this version? Thanks

[s:1thtetz0]test version removed[/s:1thtetz0]
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 08:56:02
Quote from: "menion"
Anyway, may someone test this version? Thanks

[attachment=0:3rvpt70z]2.0.0.2.apk[/attachment:3rvpt70z]

Sorry, no change here.

I am using MyPhoneExplorer (free) where I can monitor over WLAN processor, signal level, battery power).


Edit:
I found these entries in logs:

----------  25.02.2012 06:20:21  ----------
TAG:TileCache
MSG:run() - while (!requests.isEmpty())
TRACE:java.lang.NullPointerException
   at menion.android.maps.a.c.run(L:370)
   at java.lang.Thread.run(Thread.java:1096)

----------  25.02.2012 06:20:21  ----------
TAG:TileCache
MSG:run()
TRACE:java.lang.NullPointerException
   at menion.android.maps.a.c.run(L:383)
   at java.lang.Thread.run(Thread.java:1096)
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 09:11:19
these error are just when you end application, anyway they're not a problem. Did you checked correct version? It's Locus FREE, not Pro version. So you'll probably see ads at top, Shop will not work and version in info screen will be 2.0.0.2. Because for me it works correctly now

EDIT: sorry, in description in app is still 2.0.0.1, but it's already 2.0.0.2 :)
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 09:21:46
I downloaded this version 2.0.0.2.apk from your link, but the version inside in AndroidManifest.xml is 2.0.0.1 and installed is 2.0.0.1 (I deinstalled of course version from yesterday evening).
Did you make a mistake?
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 09:39:28
Quote from: "menion"

EDIT: sorry, in description in app is still 2.0.0.1, but it's already 2.0.0.2 :)

Even I start with an empty locus-directory I have the 100 %.
Title: Re: [APP] - version 2.0.X
Post by: Starman on February 25, 2012, 09:44:45
Menion-

I show this new Free version also as 2,0.0.1
Performs well on my HTC EVO 4G. Pan the vector map and the tiles snap right in. Change zoom and regenerates quickly.

To monitor CPU, I use "Usage Timelines Pro". A free version is available.
It places a handy 3 bar color graph in the notification bar, and if I pull open the notification page it gives a wider timeline.
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 25, 2012, 10:56:39
Quote from: "menion"
Huawei is working and same problem on my phone also. Anyway all methods return useless results. So by comparing older codes I changed also one think and it reduces vector maps loading time on U8120 phone from cca 4 minutes to 20 secs. May you suggest me some application that show me processor usage (perfectly in system bar) so I can also check that all is working fine?

Anyway, may someone test this version? Thanks

[attachment=0:3qet3i5f]2.0.0.2.apk[/attachment:3qet3i5f]

Good morning,

I tried your provided 2.0.0.2 and with my smaller vector maps of bavaria only (230 MB) the rendering speed appears to be ok. Then I switched back to my germany map (1.1 GB) and the map gets rendered to a white screen. The "Loading..." disappears but it renders to a blank screen!

But perhaps you are on the right way, hopefully!

Could it have something to do with smaller devices that have slower cpu's? I especially bought such a device to use it for geocaching with the pro version of your app and offline maps - not even using a sim card. But since version 2.0.0.0 it is absolutely useless :-(

sukmar
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 25, 2012, 11:14:37
It's me again.

I did the following now:

I installed Titanium Backup on my 8160 and copied a backup of Locus Free 1.16 from my other device to the 8160, deinstalled all locus versions, did a reboot and restored the 1.16 on it. The strange thing is: The problem remains!!! Now even with the former working 1.16 version it is not working any longer!

Did you change / influence other components or did you changes to the map itself?

Thanks in advance,

sukmar
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 11:34:18
Quote from: "sukmar"
It's me again.



Did you change / influence other components?

sukmar

I have the same suspicion:
After a reboot the processor sways between 10-15%,
after starting Locus  (with 100%) and stopping the processor sways between 15 and 25% without doing something.

In the taskmanager there is nothing to see.
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 25, 2012, 11:54:28
The next update from me:

I deleted the germany map on the phone and copied the orginal from my pc to it and now with locus free 1.16 the rendering is ok! Then I downloaded the pro version from market (2.0.0.0) and installed it, but here the problem resists!!!

So now: Free 1.16 is working - Pro 2.0.0.0 is not

Hopefully the pro will not "destroy" the map again!

Let me know if I can somehow support you solving this issue!

sukmar
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 12:25:00
I too extracted v1.16.3 pro from an oldTitanium Backup and installed it over the v2.0.0 and all is working as before (no problems with sqlitedb- and vector-maps).

So I am awaiting the next free betas to test before I upgrade my pro version.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 12:58:35
ufff, five hours of searching and testing ... looks like some issue on Android below 3.x (and even just some of them) ...

[attachment=0:32afax6f]2.0.0.3.apk[/attachment:32afax6f]
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 14:04:43
Quote from: "menion"
ufff, five hours of searching and testing ... looks like some issue on Android below 3.x (and even just some of them) ...

[attachment=0:28epi4bh]2.0.0.3.apk[/attachment:28epi4bh]

The 100% problem seems to be gone but this version does not load any sqlitedb- or vector maps :-(
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 25, 2012, 14:35:22
I replaced my working 1.16 free Version with your provided new version and it still seems to work, rendering of germany map is ok. Can you somehow provide me a fixed pro version for testing if I can prove you somehow having paid for it?
Title: Re: [APP] - version 2.0.X
Post by: babi on February 25, 2012, 14:50:18
Looks like it's working well. But it still doesn't remember zoom level from previous session.

Sent from my HTC Wildfire S using Tapatalk
Title: Re: [APP] - version 2.0.X
Post by: gynta on February 25, 2012, 15:10:53
Quote from: "babi"
Looks like it's working well. But it still doesn't remember zoom level from previous session.
You're right!

...and sometimes after a newstart i can scroll the map only a minimal distance
and, curiously, the loaded track moves normal -  but doesnt fit on the map. :geek:

(i will make a videoclip if i can reproduce this bug...)

edit:
 ahh. Locus remember the zoomlevel but dont show the map with this.
 otherwise the track works with the "old" zoomlevel. so track scrolls/moves normal.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 15:17:17
lloks like a conspiracy against new version :)

sukmar: I hope I'll release today new version if all will works fine (Pro is same code as Free version)
babi, gynta: zoom level of vector map or every map? So you end application with zoom let's say 12, and when you start locus again, there is different value?
tramp: are you sure? Seems you're leader of this conspiracy :))
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 25, 2012, 15:17:47
Quote from: "tramp20"
Quote from: "menion"
ufff, five hours of searching and testing ... looks like some issue on Android below 3.x (and even just some of them) ...

[attachment=0:iggp5ea4]2.0.0.3.apk[/attachment:iggp5ea4]

The 100% problem seems to be gone but this version does not load any sqlitedb- or vector maps :-(

Try a "fresh" map as I did! Perhaps it will work then?
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 15:20:25
Quote from: "tramp20"
Quote from: "menion"
ufff, five hours of searching and testing ... looks like some issue on Android below 3.x (and even just some of them) ...

[attachment=0:1tsweaeo]2.0.0.3.apk[/attachment:1tsweaeo]

The 100% problem seems to be gone but this version does not load any sqlitedb- or vector maps :-(


I tried the v2.0.0.3 without GPS (in house) and without a loaded track so Locus does not show the correct position on the loeded map.
This is now ok for vector and sqlitedb maps :-)

But the problem still exists that the processor runs now at 10 % higher than with locus pro v.1.16.3 and even after stopping the v2.0.0.3 the processor load is 10 % higher as before. I have to reboot the phone to get a deeper load (with the 1.16.3 all is perfect).
Title: Re: [APP] - version 2.0.X
Post by: gynta on February 25, 2012, 15:26:44
Quote from: "menion"
babi, gynta: ...and when you start locus again, there is different value?
sqlitedb
ending with 12 and starts with 7

edit
Locus remember the zoomlevel but dont show the map with this.
otherwise the track works with the "old" zoomlevel. so track scrolls/moves normal.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 15:37:28
Quote from: "gynta"
Quote from: "menion"
babi, gynta: ...and when you start locus again, there is different value?
sqlitedb
ending with 12 and starts with 7

that's what I needed to know .. fixed
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 15:44:19
Quote from: "menion"
lloks like a conspiracy against new version :)


babi, gynta: zoom level of vector map or every map? So you end application with zoom let's say 12, and when you start locus again, there is different value?
tramp: are you sure? Seems you're leader of this conspiracy :))

To the zoom level:
1. I start locus with a vector map and a track.
2. I change to a sqlitedb map: the zoom level seems to be the same.
3. I restart locus then (!! next problem below!!) and change now to the vector map again the zoom level is some steps smaller.


New problem after point 3: the sqlitedb map is loaded with a small zoom level, the track is shown in the same size as before, but I can shift the map independent from the track. After the next change to vector maps and back this behavior has gone. I could reproduce this several time. In v1.16.3 I did not see this.


Edit: I will stop testing today.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 15:46:15
Quote from: "tramp20"
But the problem still exists that the processor runs now at 10 % higher than with locus pro v.1.16.3 and even after stopping the v2.0.0.3 the processor load is 10 % higher as before. I have to reboot the phone to get a deeper load (with the 1.16.3 all is perfect).

what you mean "even after stopping"? When you close Locus by dialog (Yes close), then even after that you have 10% higher CPU usage then with closed 1.16.3? This is not possible because Locus close itself with unix 'kill' command so there will not be any background process or something like this.
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 25, 2012, 15:57:56
Quote from: "menion"
Quote from: "tramp20"
But the problem still exists that the processor runs now at 10 % higher than with locus pro v.1.16.3 and even after stopping the v2.0.0.3 the processor load is 10 % higher as before. I have to reboot the phone to get a deeper load (with the 1.16.3 all is perfect).

what you mean "even after stopping"? When you close Locus by dialog (Yes close), then even after that you have 10% higher CPU usage then with closed 1.16.3? This is not possible because Locus close itself with unix 'kill' command so there will not be any background process or something like this.


Yes, exactly.
I saw this since the first v2.0.0.x,  on my phone I can reproduce this.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 16:09:13
I don't know but when I close locus (with confirmation) and then immediately after that go to some task manager, locus after around a 5 sec disappear because is killed by system. How is then possible to take some CPU usage when process is killed?
Title: Re: [APP] - version 2.0.X
Post by: dibrial on February 25, 2012, 19:18:31
After importing caches into Locus via the G4L add-on, the whole categorie in which they are imported is not shown anymore and has to be activated again. Is this a Locus or G4L issue?
Title: Re: [APP] - version 2.0.X
Post by: dibrial on February 25, 2012, 19:22:00
When long clicking on a location and selecting G4L, the current GPS coords are shown in the add-on and not the clicked coords. Is this a Locus or G4L issue?
Title: Re: [APP] - version 2.0.X
Post by: menion on February 25, 2012, 19:29:42
1. check "View after import" when you import new data
2. update to Locus 2.0.1
Title: Re: [APP] - version 2.0.X
Post by: dibrial on February 25, 2012, 19:34:41
Got it. Thanks.
Title: AW: [APP] - version 2.0.X
Post by: jusc on February 25, 2012, 21:14:49
Sorry,  but I can't see any of the problems which are discussed here with the market version 2.0.0.
All works fine. (Loads fast vector maps with the same zoom level as before and no problems with CPU or RAM on SGS2. Are you sure, that it is a problem
of Locus?
Tapatalk@SGS2
Title: Re: AW: [APP] - version 2.0.X
Post by: gynta on February 25, 2012, 21:22:49
Quote from: "jusc"
...vector maps with the same zoom level as before...
talking about sqlitedb...

Now works fine. thx Menion.
Title: Re: [APP] - version 2.0.X
Post by: sukmar on February 25, 2012, 21:28:32
I just updated to 2.0.1 pro and all problems have gone, thanks a lot for the quick help!

@jusc: Perhaps it was an issue on low peformance devices but not everyone has or wants such high power devices.

Especially for the outdoor usage a long lasting battery is more important than a fast CPU!
Title: Re: [APP] - version 2.0.X
Post by: tramp20 on February 26, 2012, 05:17:32
Quote from: "menion"
I don't know but when I close locus (with confirmation) and then immediately after that go to some task manager, locus after around a 5 sec disappear because is killed by system. How is then possible to take some CPU usage when process is killed?


Good morning,
with the new v2.0.1 all my problems with Locus have gone :-)

Thank you for your hard work yesterday.
Title: Re: [APP] - version 2.0.X
Post by: menion on February 26, 2012, 08:37:06
uff, good to hear!
Title: Re: [APP] - version 2.0.X
Post by: corbas on February 26, 2012, 13:14:12
OK, i have just download new locus pro from market, and vector maps are working well. Very fast redraw, tnx
Title: Re: [APP] - version 2.0.X
Post by: menion on February 29, 2012, 21:21:01
So seems, no more serious issues. Perfect ...

Now I have another question and wish on you. Posting testing version here on forum is nice, anyway I usually see after few days around 100 downloads but only few of you (and always same people) react and communicate with me about problems of testing version etc. I also sometimes do not want to post new version for testing because I'm not sure if version is ready and perfectly working etc ... so: my idea is, that I'll create and share one folder on dropbox, that will server as testing directory for communication. People that will be invited will have access for testing versions (if they'll want to test), also ability to simply post some logs or wrongly handled files directly to me etc ... what you think? If you agree (and you're at least little bit known here on forum :) ), send me you name for invitation by PM ... or any better idea?

PS: I have rewrote today (damn whole day work) completely system for KML handling. Nothing changed in usability but helped me and opened space for future improvements, so I'll be glad to test some more KML files then few I have home. Yes and also I have done one nice surprise that you'll for sure like ...

PS2: if you don't have dropbox account, create one here http://db.tt/0k2Hrde (http://db.tt/0k2Hrde) ;) (this gives me also 250MB, just for your info)
Title: Re: [APP] - version 2.0.X
Post by: gynta on February 29, 2012, 22:07:27
Quote from: "menion"
...but only few of you (and always same people) react and communicate with me about problems of testing version etc.
wait until the weather gets better :mrgreen:
Title: Re: [APP] - version 2.0.X
Post by: gynta on February 29, 2012, 22:50:00
In the new version i see all maps will be smoothed now. (see it on Vector ans sqlitedb)
Could there be some problems now? (e.g. for older devices)
see shots v2.0.1  <=> v1.16.3.2:
Title: Re: [APP] - version 2.0.X
Post by: menion on March 01, 2012, 13:02:28
hmm didn't expect difference, nice ... no I don't expect problems on older devices, at least there are non reported

and testing version on dropbox. You'll be probably surprised with XML file. This is my definition of news that I put directly into app, so better for me then to rewrite this to some text file for you ...
Title: Re: [APP] - version 2.0.X
Post by: menion on March 02, 2012, 16:38:55
seems like no one tried testing version from dropbox. I was curious what you think about small surprise. Ok, I'll release surprise now ... offline altitude calculation from SRTM files is implemented as most wanted Idea on getSatisfaction ... (and bonus is direct automatic download of missing files from internet) ...
Title: Re: [APP] - version 2.0.X
Post by: tommi on March 02, 2012, 17:08:36
Quote from: "menion"
seems like no one tried testing version from dropbox. I was curious what you think about small surprise. Ok, I'll release surprise now ... offline altitude calculation from SRTM files is implemented as most wanted Idea on getSatisfaction ... (and bonus is direct automatic download of missing files from internet) ...
Sorry, Menion. You are too fast for me.
Title: Re: [APP] - version 2.0.X
Post by: menion on March 02, 2012, 17:20:28
no problem :D
Title: Re: [APP] - version 2.0.X
Post by: gynta on March 02, 2012, 18:25:00
Quote from: "menion"
seems like no one tried testing version from dropbox.

? i use it since yesterday!
Title: Re: [APP] - version 2.0.X
Post by: menion on March 02, 2012, 18:41:38
and did you tried to fill altitude for points/track etc?
Title: Re: [APP] - version 2.0.X
Post by: tommi on March 02, 2012, 21:43:35
Quote from: "menion"
and did you tried to fill altitude for points/track etc?
I tried it now with 2.0.1.4. It's amazing, the track I recorded earlier today with the bad altitude got now quite exact altitude information!

However the user interface for this is a bit beta:
Process Download, after few seconds "Process successful", but stays still in the Fill altitude menu.
Altitude didn't get filled in the track.
Then I press again Download and now after "Process successful" it returns from the menu and the altitude is filled in in the track.

In addition the file <coordinates>.hgt.zip should be removed after download.

Nevertheless a beautiful new feature which just needs a bit more fine tuning.
Locus, what else?
Title: Re: [APP] - version 2.0.X
Post by: menion on March 03, 2012, 09:10:41
hmm thanks for report. Seems like some issue on your side because original zip file should be deleted. After successful download, left button should change from "download" to "offline" and compute should work. Anyway this should be done automatically, right. So thanks, I'll tune it a little bit ...
Title: Re: [APP] - version 2.0.X
Post by: merilius on March 03, 2012, 22:48:22
From facebook
*** 2.0.2 ***
- fix: disabling of GPS when display is off;

So do I understand correctly that now if I quickly want to check where I am, I need wait for GPS fix each time after turning the screen on? IMHO not great.
Title: Re: [APP] - version 2.0.X
Post by: stebu on March 04, 2012, 10:33:00
Quote from: "merilius"
From facebook
*** 2.0.2 ***
- fix: disabling of GPS when display is off;

So do I understand correctly that now if I quickly want to check where I am, I need wait for GPS fix each time after turning the screen on? IMHO not great.
There's a setting that controls this action. Settings/GPS/Disable when hidden.
If you leave this box un-ticked, the GPS will stay on.
Title: [APP] - version 2.0.X
Post by: gynta on March 04, 2012, 23:52:58
BlueTooth GPSdevice:
# There is no sound on SATfix. (enabled notification with a beep in the settings)
# There is no sound if i lost GPSsignal. (enabled with a 10sec beep in the settings)
# If i go inside the House with my BTDevice (BT conected with Locus) - Locus does not recognize there is no more Signal from the BTDevice.
# If i turned off my device - Locus does not recognize there is no more Signal from the BTDevice.
Testet with SGS2(2.3.5) & SGTab10.1(3.2) and RoyalTek BT2003 SIRFIII
Can someone please check this?
Title: Re: [APP] - version 2.0.X
Post by: menion on March 05, 2012, 06:09:56
I'll check :). I can confirm missing sounds because I never did this. I'll also test rest because some similar issues are also on getSatisfaction so it surely need some improvement
Title: Re: [APP] - version 2.0.X
Post by: Robin99 on March 06, 2012, 10:50:42
Quote from: "gynta"
BlueTooth GPSdevice:
# There is no sound on SATfix. (enabled notification with a beep in the settings)
# There is no sound if i lost GPSsignal. (enabled with a 10sec beep in the settings)
# If i go inside the House with my BTDevice (BT conected with Locus) - Locus does not recognize there is no more Signal from the BTDevice.
# If i turned off my device - Locus does not recognize there is no more Signal from the BTDevice.
Testet with SGS2(2.3.5) & SGTab10.1(3.2) and RoyalTek BT2003 SIRFIII
Can someone please check this?

Ok. How about gps fix lags when you're using BT GPS device? I've reported this problem some time ago. When I go to satelites view, there is "last fix gpx" timer. I've 5 to 10 secs lags there. When I use external application to connect bt device (eg. Bluetooth GPS) gpx fix is refreshing much more frequently (about 1sek).
Do you have something like this?
Title: Re: [APP] - version 2.0.X
Post by: joeloc on March 08, 2012, 09:08:54
Ignoreme