Re: [APP] - version 3.38.+ ( 22. 5. 2019 )

Started by Menion, May 22, 2019, 13:23:28

0 Members and 2 Guests are viewing this topic.

Menion

Important links
- blog post about major version (not yet published)
- list of news of public versions

Versions
22. 5. 2019 - Locus 3.38.0
...
13. 6. 2019 - Locus 3.38.4
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

bezel

Thanks menion for your work!

Will there be an automatic map change (loading) now with the "new" openandromaps V4?
  •  

Tom

Thank you for the new version, but now all my map themes are gone. I even cannot not find a setting for changing the new default (but ugly) theme. Did I miss a new menu point?

Best regards,
Tom
  •  

Tom

Ok, I didn't realise that the app switched back to the online map by default. So, after choosing a vector map I got my themes back. Rendering is great now. Thanks!

BR Tom
  •  

Menion

Hi guys,
@bezel
give it a try. New V4 should fully support auto-loading system. Because it is first attempt, it may not be 100% reliable so feedback is welcome of course.

@Tom
all themes are gone, hmm. Be you, I should firstly check, if they are (themes) in directory Locus/mapsVector/_themes. If they are correct there (mainly it's *.xml files), check default directory defined for vector maps in Locus Map > settings > misc > default directories.
Then suggest to check if you zse V4+ vector map. If even here all will be ok, best should be if you pack your "_themes" directory to zip and send me it for test together with information, which vector map use for test.
---
Ah ok :) (reaction to new post)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

tramp20

@menion
1. why do I have now a 10 sec delay with a black screen (free and pro) before the init screen appears?
2. from old thread https://forum.locusmap.eu/index.php?topic=6502.msg55408#msg55408
as expected both Locus maps have stopped auto backup on y Z1c Pie 9.0 :-(

Is there a possibility to start the auto backup with MacroDroid for now?

If you want again a catlog please tell me what to filter.
Sony Xperia Z1c   Android 11 LOS 18.1
Sony Xperia 5 ii    Android 12
  •  

CabrioTourer

#6
With 3.38 Free I lost all folders for tracks and points.
If I use old released 3.37 pro the folders are there.
  •  

tramp20

Quote from: CabrioTourer on May 23, 2019, 16:20:50
With 3.38 Free I lost all folders for tracks and points.

I have all tracks but no favorites .
Sony Xperia Z1c   Android 11 LOS 18.1
Sony Xperia 5 ii    Android 12
  •  

Menion

@tramp20
1. have no idea. Does this happen everytime you start the app or just after the update?
2. interesting problem. No support for Tasker or similar app exists currently.
What I suggest: set automatic backup to once a day and let it be. The app may really start backup in defined time +- few hours! App also needs a valid wi-fi connection. I plan to change the logic behind to one more reliable system, but it will need some time.

@CabrioTourer
Free version does not support "Folders". They are anyway stored in the database, so data are not lost.

@tramp20
what you mean by "favorites"?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download

tramp20

Quote from: menion on May 23, 2019, 17:16:54
@tramp20
1. have no idea. Does this happen everytime you start the app or just after the update?
2. interesting problem. No support for Tasker or similar app exists currently.
What I suggest: set automatic backup to once a day and let it be. The app may really start backup in defined time +- few hours! App also needs a valid wi-fi connection.

@tramp20
what you mean by "favorites"?

Favorites: see screenshot, I had a icon for "at home".

to 1: this happens almost every time I start the app.
to 2: I use your apps from the beginning and should have enough experience :-)
The timer is set to daily, WLAN is ofc on, the backup never happens (even waiting some days), the date for the next planned backup is no longer updated. But after a occasionally reboot perhaps the next day the missing update starts automatically.
Neither a auto backup to the SDCard or to the cloud does happen.
The failure started with the last betas.

If you need a catlog at the planned start of a backup please answer how to do.
Sony Xperia Z1c   Android 11 LOS 18.1
Sony Xperia 5 ii    Android 12
  •  

Die Batzen

Hi menion,

thanks a lot for the hard work and the new version!
Some feedback:

  • offline multi language maps entries are shown two times each: in Maps-Offline as well as in Quick Map Change:
     

  • LM doesn't want to close as intended: neither button down right + confirm
       
    nor button down left and afterwards LM cross button top right
       
    closes LM - it's still running (the two pictures on the right each show the status after the attempt to close).

    As a workaround, button down right - confirm - button down left - cross top right closes LM.

Regards,
Thomas

LM 3.38.0
Android 7.0
Samsung A3 2016
  •  

balloni55

Quote1. why do I have now a 10 sec delay with a black screen (free and pro) before the init screen appears?
for me the delay take always ~5 sec
Locus Map Classic 3.63.0 AFA
Locus Map 4.12.2.5 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

Tapio

#12
Oh, a huge update, thx. Will test, so interested in working mfv4 maps and theme system.
But what I see is still sad... Newest Elevate and a v4 map, and the city name overshadowed by "Wohnwagen-Platz"... Sizes of town/city names like totally random.
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •  

Tapio

#13
Attached: Kompass map at an awful zoom level. Seems like online maps are increased and interpolated drastically at times, in order to get readable text sizes. I have seen lots of blurriness on online msps.
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •  

Tapio

It seems the route recalculation with track priority is now working well and routing me to a useful point on track consistently. Looks like I can give it a new chance. Very much appreciated.
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •