Author Topic: locus maps pro gets stuck during initialzation  (Read 188 times)

Offline nichtderschonwieder

  • Newbie
  • *
  • Posts: 2
    • View Profile
locus maps pro gets stuck during initialzation
« on: July 01, 2018, 20:12:12 »
Dear Forum,
this is my first post here. so, if this is the wrong place to ask questions like this, please guide me to the proper place

I run a Samsung Galaxy Note 3 (SM-N9005) with a Android 7 Nougat
(lineage-14.1-20180628, addonsu-14.1-arm, open_gapps-arm-7.1)
with 32 gb of internal storage, about 29 gb are free.

Today, I have downloaded a purchased version of the recent locus maps pro
 via Google Playstore using my playstore-account.

There are no errors or warnings indicated during the installation process,
several folders are created in the internal storage,
and finally I am asked to open Locus.

And here Locus gets stucked: the first locus screen asks me to accept the terms of use, and then there's
the second screen saying "Initialization  ....   Working" and some kind of progress bar
see attached:



I have repeated this several times.
Also, I have been waiting once 30 minutes, forcing the screen to stay awake.

Then I uninstalled Locus Pro and installed the Locus Free, suprise!
Locus Free needs 4-5 seconds in the "Initialization  ....   Working" screen,
and it is completly usable (lo-offline maps, import backup, manually draw routes...)




Is this a license issue?
FYI: I use Locus Pro successfully on another Android device with the above mentioned playstore account



Regards,
Alex


 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 10636
  • Thanked: 157 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: locus maps pro gets stuck during initialzation
« Reply #1 on: July 03, 2018, 08:43:32 »
Alex, sorry for a complication.
Please read our post here: http://help.locusmap.eu/topic/problem-with-locus-map-pro-initialization-at-startup
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 
The following users thanked this post: nichtderschonwieder

Offline nichtderschonwieder

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: locus maps pro gets stuck during initialzation
« Reply #2 on: July 05, 2018, 18:25:36 »
Hi menion,
thank you for the link, I will definitely keep an eye on this article.
I'm glad that this is a general interest issue and not just my device is affected by this.

----------------------------

In the meantime, I have done some more trial-and-error testing:
I have re-installed the latest  stock firmware (Android 5.0 Lollipop) for the samsung note 3, which was first published in 2016.

 Then installed locus maps via lollipop-playstore - voila!
Locus maps pro is running as usual, no authentication issues.
Interestingly, the Locus-Maps-Pro-Version I can access  Locus maps pro has a file size of about 30 MB in the Lollipop-Playstore.

In comparison, the file size of the Locus-Maps-Pro-Version I can access in the Lineage14.1-playstore has a file size of 15 MB

the recent Lineage14.1-playstore  has build version 10.7.17

I will now try to get the the work-around to work presented by Mr. Voldan in http://help.locusmap.eu/topic/problem-with-locus-map-pro-initialization-at-startup

-------------------------------

EDIT 18:37
I manually upgraded to Playstore 10.7.19
and now Locus-Mpas-Pro is working like charm!

Thank you, menion

------------------------------


 Locus-Maps-Pro is still the best Map-App I know, and I'm sure this issue is going to be solved



« Last Edit: July 05, 2018, 18:39:52 by nichtderschonwieder »
 

Offline Tw2long

  • Newbie
  • *
  • Posts: 1
    • View Profile
  • Device: S8
Re: locus maps pro gets stuck during initialzation
« Reply #3 on: July 11, 2018, 19:54:47 »
I thought it was only me having this issue. I upgraded my Playstore version like you and it fixed it.