Author Topic: nach Marshmallow-Wechsel: Probleme mit Locus - Speicherort / SD-Karte  (Read 4341 times)

Offline balloni55

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 2096
  • Thanked: 58 times
    • View Profile
  • Device: Motorola G3 MM 6.01, SGS2 CM14 7.1
um besser Auskunft geben zu können habe ich heute auf meinem alten SGS2 CM 13 :D
Locus und BRouter komplett gelöscht, wieder neu installiert und eine neu fat32 formatierte SD eingesetzt.
hab dann zuerst auf der externen SD die Ordner angelegt, siehe SS
Als nächstes die externen  Pfade angelegt, siehe SS
- download einer Karte aus dem Store mit Höhendaten, Karte wurde auf der ext SD unter mapsVector und die Höhendate auf der ext SD unter data_strm ohne weiteres Zutun gespeichert
- ein Test Backup landete auch im richtigen Ordner auf der ext SD


als nächstes werd ich versuchen die "segments4" von Brouter auf die ext SD zu verschieben und die storageconfig.txt ändern, mal sehen ob das auch funktioniert

EDIT:
auch das funktioniert ;D
zuerst auf der ext SD einen Ordner "brouter_segments4" angelegt,
als nächstes auf der internen SD, wo BRouter installiert sein muss  die "storageconfig.txt" geändert, Achtung das # muss entfernt werden! anschließend gespeichert !!, siehe SS

nun die Datenfiles von der internen SD auf die ext SD in den "brouter_segments4" Ordner verschoben
Nach einem Neustart des SGS2 funktioniert das routing  perfekt 8)
« Last Edit: August 06, 2016, 20:58:25 by balloni55 »
Locus PRO 3.27.1
 
The following users thanked this post: jusc

Offline jusc

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 1883
  • Thanked: 16 times
    • View Profile
  • Device: Samsung Galaxy S2 and Note 2
@balloni

vielen Dank für Deine Hilfestellungen.

(Man kauft sich für hunderte Euros ein Smartphone, gibt nochmal 100,-€ für eine größere SD-Card aus und dann werden schon nach kurzer Zeit keine (Android-) Updates mehr angeboten, oder man  muss sich mit so einem Mist rumschlagen.
Wieviel Zeit für die Recherchen und Tüfteleien zur Nutzung von Locus und/oder BRouter damit draufgehen, da darf man nicht drüber nachdenken.)
Regards J.
 

Offline Graf Geo

  • More than Newbie
  • *
  • Posts: 54
  • Thanked: 1 times
    • View Profile
Re: nach Marshmallow-Wechsel: Probleme mit Locus - Speicherort / SD-Karte
« Reply #17 on: January 20, 2017, 14:40:18 »
Nochmal zu diesem Thread:

Nachdem ich es im ersten Versuch vor wenigen Wochen nicht hingekriegt habe, die segments4 mit den *.rd5 Dateien von der externen Karte laufen zu lassen, hat es heute im 2. Versuch doch geklappt.  :)
Vermutlich habe ich beim ersten Mal doch irgendeinen Tippfehler in der storageconfig.txt oder ein # falsch gemacht .

Jetzt sind auch die letzten speicherintensiven Dateien im Locus-Umfeld auf der SD-Karte. Daher nochmals mein Dank an balloni55 für seine super Anleitung!

Neu heruntergeladene *.rd5 Dateien werden zwar weiterhin im internen Speicher abgelegt, aber das Verschieben auf die externe Karte ist ja kein Akt - zumal das ja nicht gerade oft anfällt.

Bei der Gelegenheit wundert es mich, dass sich gar keine Programmdateien o. ä. im internen Speicher, wo BRouter installiert ist, finden lassen. Ich habe dort nur ein Verzechnis "brouter" mit den 4 Unterverzeichnissen modes, profiles2, readmes und segmens4, in denen sich aber nur Profil- und Textdateien (*.txt, *.dat und *.brf) befinden.

 

Offline franc

  • Padavan of Locus
  • ***
  • Posts: 389
    • View Profile
Ich musste auch erst das Xposed Modul XInternalSd installieren damit das ging.

Leider hat das Modul dann herum gesponnen und mein SGS4 voll ausgebremst. Hatte auch eine lästige lange Weile gedauert bis ich es als Verursacher ausgemacht und deaktiviert hatte :(

Ich dachte in der Zwischenzeit gäbe es das Problem endlich nicht mehr, durch Update repariert hoffte ich, andere Apps können das mittlerweile ja auch (der Benutzer muss dazu explizit einmal die Berechtigung erteilen dass das Programm auf die externe schreiben darf), aber Pustekuchen.
Kam dann wieder diese lästige Auswahl beim Locus Start und dann geht es auch nicht mehr.
Habe also wieder XInternalSd aktiviert und Locus geht wieder.
Wie lange es dauert bis das Modul wieder spinnt weiß ich noch nicht...

Ohne Modul:

Mit:

« Last Edit: June 24, 2017, 15:36:44 by franc »
Locus Pro - always the actual version on Samsung Galaxy S4 with Lineage 13
 

Offline franc

  • Padavan of Locus
  • ***
  • Posts: 389
    • View Profile
zur roten Problemmeldung "mapsVector" hab ich eine Vermutung, geh mal  im Offlinkarten Tab auf da +, dann auf externe Karten und schau dort in der oberen Hälfte ob dort noch ein altes "mapsVector" Verzeichniss aufgeführt ist mit 0 Dateien.
Wenn ja entferne dieses
Da hatte ich zwei Einträge drin, einen fehlerhaft, einen korrekt, wohl aber unnötig weil ich ja direkt auf der externen das Locus Verzeichnis habe.
Habe daher beide Einträge mal gelöscht.
Werde vielleicht aber auch noch mal Marshmallow Sd fix probieren (xda-Thread), wenn das XInternalSd wieder spinnt. Gemäß einem Tipp in der Locus HelpDesk
« Last Edit: June 24, 2017, 15:58:32 by franc »
Locus Pro - always the actual version on Samsung Galaxy S4 with Lineage 13