Author Topic: Mapsforge 0.5  (Read 32301 times)

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 10054
  • Thanked: 69 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Mapsforge 0.5
« Reply #120 on: April 10, 2016, 20:32:50 »
It's already done ;)...  Just not yet public. It will anyway need new map (version 4+) and new theme (version 4+). Themes you probably already have, but any map for tests? Thanks

Tapatalk

Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline kech61

  • Apprentice of Locus
  • **
  • Posts: 166
  • Thanked: 3 times
    • View Profile
Re: Mapsforge 0.5
« Reply #121 on: April 11, 2016, 08:13:59 »
Hi Menion

These are really good news.

Theme with priority support: http://www.openandromaps.org/wp-content/users/tobias/Elevate3_SVG.zip
With this Theme you can test scaling of SVG's too - if you want  ;)

V4 multilingual map: http://www.openandromaps.org/mapsV4/asia/israel_syria_ml.map
This is the only V4 maps so far on OpenAndroMaps
However, I can make any map you need for testing, just tell me which map you want to have.


« Last Edit: April 11, 2016, 08:28:45 by kech61 »
Best regards/ Grüsse
Christian
www.openandromaps.org
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 10054
  • Thanked: 69 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Mapsforge 0.5
« Reply #122 on: April 11, 2016, 08:57:36 »
Thanks Christian, I'll look at it.

Also maybe useful info for others. I have decided to go little bit different way in the end. Since next version will be in Locus three versions of MapsForge library :).

- quite old for maps version V2
- heavily modified and optimized library for all maps V3 (LoMaps and most of current maps) that will also work with themes version 1, 2, 3, will offer auto-loading and work with LoMaps Poi DB
- current unmodified version of MapsForge library (currently version 0.6, maps V4) that will work only with map themes version 4, no autoloading, no POI Db

Locus automatically decide which map renderer use by version of map.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline kech61

  • Apprentice of Locus
  • **
  • Posts: 166
  • Thanked: 3 times
    • View Profile
Re: Mapsforge 0.5
« Reply #123 on: April 11, 2016, 11:49:49 »

Locus automatically decide which map renderer use by version of map.

Perfect  :)
The Theme in the link is for plain Mapsforge V4 w/o any special Locus elements.

There are Mapsforge pois available from OAM too - so if you want to test those with the plain V4 renderer:
http://ftp5.gwdg.de/pub/misc/openstreetmap/openandromaps/pois/
The mapname.poi.zip are the right ones
« Last Edit: April 11, 2016, 12:17:38 by kech61 »
Best regards/ Grüsse
Christian
www.openandromaps.org
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 10054
  • Thanked: 69 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Mapsforge 0.5
« Reply #124 on: April 11, 2016, 12:30:59 »
Not needed, thanks. No Mapsforge POI will be supported for now, only a map.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline Tobias

  • More than Newbie
  • *
  • Posts: 72
  • Thanked: 2 times
    • View Profile
    • Elevate themes
Re: Mapsforge 0.5
« Reply #125 on: April 11, 2016, 13:52:46 »
That's excellent news, thanks!

Locus automatically decide which map renderer use by version of map.
Also by version of map theme?
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 10054
  • Thanked: 69 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Mapsforge 0.5
« Reply #126 on: April 11, 2016, 14:01:31 »
Also by version of map theme?

Nope. You choose map, Locus check all available themes and offer only these, that has correct version. So for maps V3, only themes with version="1, 2, 3", for maps V4, themes with version="4".
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline Tobias

  • More than Newbie
  • *
  • Posts: 72
  • Thanked: 2 times
    • View Profile
    • Elevate themes
Re: Mapsforge 0.5
« Reply #127 on: April 11, 2016, 14:12:18 »
So for maps V3, only themes with version="1, 2, 3", for maps V4, themes with version="4".

Hm, that's a bit strict. There's no issue in using V3 maps with V4 themes. Although the numbers differ, they aren't dependent on each other. Mapsforge 0.5 introduced V4 themes, while still producing V3 maps. It would be strange to be able to install V4 themes but not to use them, and will certainly cause support issues.

So if you install and choose a V4 theme switching to standard mapsforge would make sense to me.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 10054
  • Thanked: 69 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Mapsforge 0.5
« Reply #128 on: April 11, 2016, 14:26:02 »
I knew you won't like it, but it's only option I may offer for now, thanks for understanding.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline LocusUser#1

  • More than Newbie
  • *
  • Posts: 87
  • Thanked: 49 times
    • View Profile
  • Device: Samsung S4 mini
Re: Mapsforge 0.5
« Reply #129 on: April 11, 2016, 14:35:37 »
So if you install and choose a V4 theme switching to standard mapsforge would make sense to me.

You're right, also for me is this the only correct way to use the different themes versions
 

Offline ohgood

  • More than Newbie
  • *
  • Posts: 53
    • View Profile
Re: Mapsforge 0.5
« Reply #130 on: April 13, 2016, 02:03:04 »
I would like to test this if you need help