Author Topic: [APP] - version 2.0.X  (Read 14817 times)

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9997
  • Thanked: 64 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
[APP] - version 2.0.X
« on: February 24, 2012, 10:17:53 »
24.2.2012 - Locus 2.0.0
exactly after a month, new version. Believe all will works fine, anyway bug reports (mainly due to number of news) are expected and welcome!
  • release on Android market - Free & Pro
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline jusc

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 1877
  • Thanked: 10 times
    • View Profile
  • Device: Samsung Galaxy S2 and Note 2
Re: [APP] - version 2.0.X
« Reply #1 on: February 24, 2012, 11:38:04 »
Hi menion,

I can see only the free version 2.0 in the Market. Correct?
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Regards J.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9997
  • Thanked: 64 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.0.X
« Reply #2 on: February 24, 2012, 11:40:43 »
no, both are there. Just wait a while. You know, sometimes Market do not work in ways we all want ...
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline tramp20

  • Premium
  • Master of Locus
  • ****
  • Posts: 521
    • View Profile
Re: [APP] - version 2.0.X
« Reply #3 on: February 24, 2012, 13:57:29 »
Hi,
after updating from a perfect 1.16.3 to 2.0 Locus pro reacts very slowly, vector map loads after 20 sec: the processor runs at 100 % constantly.
So where can I get the old version?
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Sony Xperia Z1c   Android 5.1.1
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9997
  • Thanked: 64 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.0.X
« Reply #4 on: February 24, 2012, 14:24:32 »
this have to have some good reason. Downgrade to older version is not solution.

Are you using any special feature? The fact that processor run on 100% means that there will be probably just one problem, one running task in Locus. Even if you leave locus for a while, this happen? If so, try to send me log from CatLog please, maybe there will be some error on background or some hint why this happen
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline corbas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: [APP] - version 2.0.X
« Reply #5 on: February 24, 2012, 14:31:20 »
Hi, I have downloaded new 2.0 version about 1 hour ago, but the same problem.
On HTC wildfire I use mostly offline / dowloaded/ vector map - slovakia.
On previous version i works well, but now it is very very slow.
To print new area, or zoom on map it takes not 20sec, but i my case about 50-70 sec and during these time is processor on 100%.
Something is wrong...

EDIT: I am sending You catlog file - start record, start locus pro- wait about 3min! for loading vector map-exit locus-stop recording.
It now really takes abou 3min for loadingand show vector map.

St.
« Last Edit: February 24, 2012, 15:52:36 by corbas »
 

Offline tramp20

  • Premium
  • Master of Locus
  • ****
  • Posts: 521
    • View Profile
Re: [APP] - version 2.0.X
« Reply #6 on: February 24, 2012, 14:41:26 »
Quote from: "menion"
this have to have some good reason. Downgrade to older version is not solution.

Are you using any special feature? The fact that processor run on 100% means that there will be probably just one problem, one running task in Locus. Even if you leave locus for a while, this happen? If so, try to send me log from CatLog please, maybe there will be some error on background or some hint why this happen

Nothing special feature.
Without locus the processor runs at 10-15 %, I never had this before.

When I stop locus the processor goes at once to these lower values.

I donĀ“t know how to use catlog (my phone is rooted).

The last err logs in locuslogs are from 10.02.2012.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Sony Xperia Z1c   Android 5.1.1
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9997
  • Thanked: 64 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.0.X
« Reply #7 on: February 24, 2012, 15:00:48 »
ok, so please when you'll have some time. Install from market program called CatLog. Then start locus and play with it a while. After that close it, run CatLog program and after few secs, when data load, from menu select "save" and send me on locus@asamm.com email with this log. Hope there will be some info because I tested it quite a lot on four devices and no similar problem for a whole time ...
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline tramp20

  • Premium
  • Master of Locus
  • ****
  • Posts: 521
    • View Profile
Re: [APP] - version 2.0.X
« Reply #8 on: February 24, 2012, 15:25:14 »
Quote from: "menion"
ok, so please when you'll have some time. Install from market program called CatLog. Then start locus and play with it a while. After that close it, run CatLog program and after few secs, when data load, from menu select "save" and send me on locus@asamm.com email with this log. Hope there will be some info because I tested it quite a lot on four devices and no similar problem for a whole time ...


Done.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Sony Xperia Z1c   Android 5.1.1
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9997
  • Thanked: 64 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.0.X
« Reply #9 on: February 24, 2012, 16:02:03 »
thanks corbas for email. Unfortunately in your log is no important info. Is this happen only with vector maps? Other maps works correctly? (or Blank map). Tramp, mail from you do not come. Maybe post it here on forum? Thanks
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline tramp20

  • Premium
  • Master of Locus
  • ****
  • Posts: 521
    • View Profile
Re: [APP] - version 2.0.X
« Reply #10 on: February 24, 2012, 16:09:19 »
Quote from: "menion"
thanks corbas for email. Unfortunately in your log is no important info. Is this happen only with vector maps? Other maps works correctly? (or Blank map). Tramp, mail from you do not come. Maybe post it here on forum? Thanks

I will try it here.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Sony Xperia Z1c   Android 5.1.1
 

Offline corbas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: [APP] - version 2.0.X
« Reply #11 on: February 24, 2012, 16:20:28 »
Problem is only with vector maps. I tried online maps, and downloaded maps/OSM,freemap/ It is working well and fast. Switch back to vector map, i need wait very long time - sometimes few minutes to draw a map, when I move on the map, the same - wait 50,100,150 or 200sec. Application is still responding , but there is only very long time for redraw vector map.Problem will be in this new version, because yesterday I used vector maps and worked well.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline tramp20

  • Premium
  • Master of Locus
  • ****
  • Posts: 521
    • View Profile
Re: [APP] - version 2.0.X
« Reply #12 on: February 24, 2012, 16:27:17 »
I have this problem with all maps, not only vector maps (e.g. with own maps generated with MOBAC in sqlitedb-format).

Edit: the sqlitedb maps are loading relative fast but the processor stays at 100 %.

Edit2: with a blank map the processor has 80 %.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Sony Xperia Z1c   Android 5.1.1
 

Offline krzysiekz

  • More than Newbie
  • *
  • Posts: 32
    • View Profile
Re: [APP] - version 2.0.X
« Reply #13 on: February 24, 2012, 18:10:40 »
On wildfire vector maps are useless now, they are loading very slow.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9997
  • Thanked: 64 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 2.0.X
« Reply #14 on: February 24, 2012, 18:40:35 »
thanks for log tramp, but unfortunately no info there. Damn, it's big mystery for me.

I have home one quite old Huywei phone so I'm now trying to install some CM version on it. Hope this will work and also that maps will not work on it. Don't worry guys, I'll fix it for sure :). Anyway as I told, quite mystery. For me all works absolutely without problem and I also do not changed anything in base map system ...
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!