Author Topic: [APP] - version 0.6.x  (Read 4434 times)

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9936
  • Thanked: 53 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
[APP] - version 0.6.x
« on: September 09, 2011, 12:36:16 »
new testing version of WhereYouGo application!
15.9.2011
- so this is RC for Android Market. I currently do not have much time to go out to test it on some real Wherigo, so if anyone want ;)
- I also suggest to finish already played cartridges. It's not sure that save files will be compatible

10.9.2011
- I have reports some map issue! I did some small updates in new version but I still don't see some problems with map display! So please report (ideally with some logs) some issues if you'll have some times and taste! Thanks ...

9.9.2011
As I can see, size of app grown unfortunately from 1 to 3MB, quite a lot. Here are reasons, together with news

- translated to 19! languages (this is almost half of size - much text is used only in Locus but there is no simple way how to separate this)
- added support for Locus online, offline (personal), vector maps
- current (8.9.2011) code from OpenWIG project
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline userxxx

  • More than Newbie
  • *
  • Posts: 17
    • View Profile
Re: [APP] - version 0.6.x
« Reply #1 on: September 11, 2011, 15:55:37 »
I had no problem with the 0.6 version, why is it now a 0.5.x version? Should I take/test this new version?
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9936
  • Thanked: 53 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 0.6.x
« Reply #2 on: September 11, 2011, 17:47:41 »
it was just a wrong numbering, doesn't matter a lot :) ... let's say that number 0.6.x = 0.5.0.1 :).
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline userxxx

  • More than Newbie
  • *
  • Posts: 17
    • View Profile
Re: [APP] - version 0.6.x
« Reply #3 on: September 12, 2011, 11:19:31 »
I can't launch version 0.5.0.2, immediatly got FC. I reloaded the previous version, seems to work fine (tested landing_of_the_roc.gwc).
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9936
  • Thanked: 53 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 0.6.x
« Reply #4 on: September 12, 2011, 11:26:36 »
do you have same problem with current version of Locus? Ah yes, I send you (already) last working version .. hmm so it's obfuscator problem that cause crashes ...

EDIT: hmm so when I know where should be problem, I was searching a little more ... please test this version! (Expect that personal maps should work wrong - I'm currently working on auto-load mechanism) - also if this will work, expect please one more test also on locus ;)
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline userxxx

  • More than Newbie
  • *
  • Posts: 17
    • View Profile
Re: [APP] - version 0.6.x
« Reply #5 on: September 13, 2011, 12:10:25 »
Ok, it works.
Not sure this is related, but I got an error message when I want to resume a previous cartridge (puzzles!).
Code: [Select]
you hit a bug! please report at openwig.googlecode.com and i'll fix it for you!
java.lang.RuntimeException: table index is nil

stack trace:
Yesterday, I had no problem to resume a cartridge.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9936
  • Thanked: 53 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 0.6.x
« Reply #6 on: September 13, 2011, 15:18:38 »
hmm and are you able to resume cartridge saved with version 0.5.0.3 or this cause troubles also?

and if this version works for you, that's very good news!! Because new locus will works for you also .. fine
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline userxxx

  • More than Newbie
  • *
  • Posts: 17
    • View Profile
Re: [APP] - version 0.6.x
« Reply #7 on: September 13, 2011, 20:03:43 »
Yes, I can resume cartridge saved with this version. Not a big deal then.
All good news :)
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9936
  • Thanked: 53 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 0.6.x
« Reply #8 on: September 15, 2011, 08:10:35 »
fine, so new version of Locus is already on market, so please let me know if on your 1.6 android all works (mainly if it start correctly). Also in first post is updated RC version of WhereYouGo. I would like to publish it on market anyway I just need some feedback first ...
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ormoru

  • Premium
  • Apprentice of Locus
  • **
  • Posts: 131
    • View Profile
Re: [APP] - version 0.6.x
« Reply #9 on: September 15, 2011, 10:03:38 »
So still not work offline maps for me. And vector maps ends with FC. I test it on SGS II.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline userxxx

  • More than Newbie
  • *
  • Posts: 17
    • View Profile
Re: [APP] - version 0.6.x
« Reply #10 on: September 15, 2011, 10:26:01 »
WhereYouGo RC works, although again I can't resume saved cartridge of previous version (but I can resume if saved with this version).
Locus 1.13.0 was giving FC
Locus 1.13.1 works
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 9936
  • Thanked: 53 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: [APP] - version 0.6.x
« Reply #11 on: September 15, 2011, 10:59:43 »
thanks perfect, so Locus is again working on 1.6. Good

about WhereYouGo saves ... yes I know, I have changed obfuscation method to old market version (and also version 0.5.something, that was published here as first)
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!