Locus Map - forum

Development => Versions => Released => Topic started by: menion on January 12, 2012, 18:52:16

Title: [APP] - version 1.16.x
Post by: menion on January 12, 2012, 18:52:16
2.2.2012 - Locus 1.16.3.2
testing version - I'm sure many of you use testing version instead of regular Pro version, so here is one :)

[attachment=0:2xa131te]1.16.3.2.apk[/attachment:2xa131te]

21.1.2012 - Locus 1.16.2

18.1.2012 - Locus 1.16.1.1
testing version

13.1.2012 - Locus 1.16.1

12.1.2012 - Locus 1.16.0
Title: Re: [APP] - version 1.16.x
Post by: GOF007 on January 12, 2012, 19:03:23
Thank You for the update ^^
Title: Re: [APP] - version 1.16.x HELP
Post by: Rob on January 12, 2012, 22:18:05
heeelp,
after installing new version (1.16) all my tracks and categories disappeared. When selecting TRACKS --> error: no tracks in categories....use import feature or filemanager...
After importing from backup (puh - god sake) in existing or new category - seams to successfully imported, but when trying to open track in TRACKS  -same error message....

pls help !
Thx

Rob

EDIT: after deleting dbtracks.sqll at least I can import tracks again and display them. But, something is strange with my categories - independent where I import the tracks to, all categories show (0/0) and cannot click/tickmark on right side...
And when I import a gpx. file named e.g. route.gpx  it is imported but is shown as 19.009    ??
I know that in previous version everything worked fine.
I´m lost....
pls help what to do. At least I have all downloaded maps and tracks exported, so no real loss, but behaviour of LOCUS is strange now...
Title: Re: [APP] - version 1.16.x
Post by: Novasilva on January 13, 2012, 02:49:33
thank you menion, this is really nice.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 13, 2012, 05:46:21
Rob please, do you have some old files for tracks? may you send me it or probably also categories and one points file for test? Also I discovered critical error in creating empty track database ... so after deleting tracks file, it works correctly for you? interesting ..
Title: Re: [APP] - version 1.16.x - HELP
Post by: Rob on January 13, 2012, 08:14:37
Hi menion,
sent requested by mail to you.....

Yes, in another post I found the hint to delete the dbtracks in case of track-problems, this is what I did, and at least I can import and display the imported tracks again.
But I cannot show them within the correct category, they are in no category....

Let´s see...

thx
Title: Re: [APP] - version 1.16.x
Post by: Rob on January 14, 2012, 07:02:45
Hi menion, 
goooood news: everything fine again with this new 1.16.1 version. I copied both db..s back from backup and - voila - I got all my tracks back.
Thx much for your support!

Rob
Title: Re: [APP] - version 1.16.x
Post by: menion on January 14, 2012, 09:21:16
you're welcome, thanks for good news ...
Title: importing tracks Umlaute problem
Post by: Rob on January 14, 2012, 14:01:06
Am I the only One with this issue?
Then it should be a question of my settings.
Can anybody help me pls?

when importing my old gpx tracks all "Umlaute"  ä, ö, ü, ...  are changed in strange letters.
I checked gpx  files with editor and names are correct. Codes are either ISO or UTF-8.
Any setting what I can change ?
Examples
 see below.

edit:  kml files are imported correctly
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 14, 2012, 19:04:09
Yes please add a function that allows the user to turn on and off the track start and stop icons that cover the map (and the name of the track) . And the blue dots that are permanantly showing at the start and stop of each track gets kind of annoying. I have short and long tracks with my own added points along the track and it completely clutters the map and tracks. I have hundreds of tracks for the desolate and barrren area I am in. Alot of tracks connect with eachother branching off like a tree and the screen is just covered with white tabs everywhere, And I am running a 10" screen tablet. the new style of Icon tabs (waypoint and track names) with the white background just clutters the screen too much. (maybe an option to make the tabs transparent and only make the font visable maybe? because you can change the color of the font but not the background) I have been using a previous version of locus from about 6 months ago and was hesitant to update it, and I did yesterday but I think I should have waited. But your map application is still by far one of my favorite things to use.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 14, 2012, 19:06:14
may you show me screenshot of your over-fill screen please?
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 14, 2012, 19:23:28
see all the stuff, it covers alot of the tracks. you have an option to turn on and off point icons and labels but not for tracks. Some  of the tracks i will manuall create with the draw function. and it seems to add just too much to the map with all the labels.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 14, 2012, 19:27:11
wait, and you want to have visible these labels or not?

if not, just menu > settings > map > show labels
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 14, 2012, 19:29:51
i dont need all the labels visible, there are labes ontop of labels, just like you have the function to turn labels on and off for waypoints, there should also be the same feature for tracks.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 14, 2012, 19:31:10
but "Show labels" settings also affect start and end points of tracks ...
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 14, 2012, 19:33:41
i just would lik to have the ability to turn the labels off for the tracks only, just like the feature for waypoints. (never, on hover, always) I like having the ability to have my manually created points to show all the time, or off if I want, but the track names is a little overkill for me. and it seems the only way to get them off the screen is to have all of the lables turned off.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 14, 2012, 19:39:54
hmm finally understand, I'll think about it ...
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 14, 2012, 19:50:02
thank you! =)
Title: Re: [APP] - version 1.16.x
Post by: menion on January 15, 2012, 14:19:52
oki, what about this ... is this new screen clear?
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 15, 2012, 16:04:03
Just something general for all settings: negative options (ie "Disable/Hide/Etc whatever") are mostly a bad idea. It requires users to ENable a checkmark to DISable a feature, which is counter intuitive. I would always use a positive option unless there's a really good reason not to. That means...

* Show extra labels

instead of

* Hide extra labels

The positive options can of course default to on or off, depending on what makes more sense.
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 15, 2012, 18:04:30
Menion, that screen looks beautiful. Options are always a good thing in my opinion. This gives the users the ability to show all labels, and or only waypoint or tracks. Bravo. And (joeloc)  options are truthfully a good thing and not negative or a bad idea, thats the whole point of a user interface. Just like Traction control in my corvette, I leave it OFF almost every time i drive it. Because sometimes the option to be in control of my car is better than the car being in control of me. In better words "Freedom"
 Thanks Menion that option screen looks awesome.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 15, 2012, 19:16:48
Quote from: "joeloc"
Just something general for all settings ...

damn Joe, you're right. I was never thinking about it from this point of view ... damn, big problem is here only fact, that every text I change have to be translated by all people again ...

and scout, you're welcome. What you by the way, think about question marks? I want to have possibility to display hint to every settings and feels like disturbing to have this hint visible all the time ...
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 15, 2012, 19:51:35
Questionmarks... well... to be honest, i would much rather see a standard android settings interface for everything. You might consider it boring now, but in fact it's simple, easy to grasp, beautiful, battery-saving. It doesnt need complicated things like extra help texts hidden behind question marks because there is plenty explaining text already, way more than with your one-word-labels. Almost all other apps do it that way, it will look pretty in ics and below, etcpp. It's just standard and people expect it.

Custom ms-windows desktop emulation things on the other hand (subwindows, close gadgets, ok/cancel buttons) are not androidish and confusing. And the more work you put into your own ui (like the question mark thingies?!), the harder it will be to "get back on the proper path" later. Of course you are in love with your own button inventions right now... but maybe that will change with time.

I think Locus can have a really fancy main screen (the map view) with loads of custom things all around, but should stick to android standards everywhere else.

Android standard. Simple, Easy to use, Beautiful.
[attachment=0:33kxc3xz]SC20120115-192729.jpg[/attachment:33kxc3xz]
Just my opinion obviously, yours may differ :).
Title: Re: [APP] - version 1.16.x
Post by: menion on January 15, 2012, 20:07:49
that's how all setting in locus looks like ... right, almost all, not all looks like this now.

problem and change comes with some more complicated settings. What about these? (on screenshots) ... they're too complicated to basic system that allow android.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 15, 2012, 20:33:23
Hm... you are right. Locus has perfectly standardized settings almost all the way already. I somehow forgot that when seeing those subwindow screenshots, sorry.

Anyway... why is that too complex for android? Because of Beep and Choose Sound? Could it not just go to the normal GPS settings page? Its quite messy right now with its "Enable notification" thing anyway. What good is that for? If I want to globally mute my phone, I just mute my phone. If I want to mute a specific gps alert, I can set it to "Mute" in the ring tone dialog.

Why would I need TWO EXTRA ways to enable/disable that specifically in Locus? Right now you have this "enable notification" checkmark thing in the main GPS settings page and then another set of checkmarks in the popup window. And then you can enable an alert but set it to MUTE in the ring tone dialog, which effectively disables it. Thats a complete triple mess :-).

The ring tone dialog comes from Android I presume? Can you add your simple "Beep" there somehow? Or maybe just the contents of locus/alerts as well as the system ringtones? Then you would not need any extra freaky gadgets but could simply offer

* GPS fix acquired alert
  "Beep"
* GPS fix lost alert
  "Andromeda"
* GPS fix lost repeat timer
  10 seconds <- defaults to 0 = no repeat.

in your main gps settings page. Thats it. No subwindow at all, no triple-checkmark crazyness.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 15, 2012, 20:39:24
with gps notification :) .. it's quite simple. I use one main checkbox for this settings (enable/disable) because this allow to use one switch in Quick switch panel, that's all. Also thanks to this, you may simply disable whole notification stuff.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 15, 2012, 20:40:36
The same is true for the Guiding Sounds window. I cant see any reason for that at all, it could just sit happily inside the normal android settings list on the Guiding prefs page.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 15, 2012, 20:48:10
So seriously... is it that important to enable/disable gps fix sounds with a single click, but for example leave guiding sounds unchanged? Does this warrant a preferences mess where i have in fact three different ways to enable/disable an alert? I think not.

Maybe one single global option to mute/unmute Locus would do. That would affect all your sounds and alerts at once, independently from the rest of the phone, and still not clutter all your preferences pages with extra windows and triple-checkmarking.

If I want finer granularity, I can enable/disable every single alert with its ringtone dialog.

But to add an extra layer of enabling/disabling here is a bit over the top really.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 15, 2012, 20:56:55
hmm I'm not sure about it ... from my live ...

sometimes, I just go to trip and use track recording. In this case, I want to have enabled GPS notification for cases when I lost GPS connection. Other case is hunting for geocaches. You see for whole time compass and screen, so you don't need notification for GPS but you need notification for Guiding ... it's question what is best.

with smile on face, I have to say that I don't know. I just think that current Locus design isn't too much against android concept (at least not too much), I also think that due to lot of functions, it quite easy to understand and that's main for now. What do better? There is a lot of things ... :)
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 15, 2012, 21:35:55
i like the way the menu system is set up now, but adding a ? hint tab to the settings sounds ok also. I love Locus and have been using it for a long time. I use it every day. But my only issue that I personally see from after updating locus yesterday is the over crowded screen and not being able to turn off the tags and labels and start and stop "dots" for tracks. And the background for the labels is always white, should have the same feature for the font color or the ability to make the label backgroud transparent. You have a great program, and the best part about it is the ability to control so many settings and that allows the user to set up the program exactly as he needs it. Unlike garmin with its limited features and settings, I think from when I first started using this program I got about 50-70 guys I work with to ditch their garmin GPS's and they now run Locus on tablets.
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on January 15, 2012, 21:38:22
Quote from: "menion"
I also think that due to lot of functions, it quite easy to understand and that's main for now. What do better? There is a lot of things ... :)
Yes correct, even though there are alot of settings and functions Locus is very easy to learn and set up.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 18, 2012, 23:07:00
testing version. In the end, I removed new "Map style" screen and placed there just basic Android settings.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 19, 2012, 13:55:08
does this have rmap debug? i cant see any. but i still want to find out what locus thinks of this 3.8GB map :-)
Title: Re: [APP] - version 1.16.1.1
Post by: gynta on January 19, 2012, 22:18:37
hi menion
1. send you a crashlog per mail.
2. on my tab some screen look very blurred:
(in the proversion its ok)
Title: Re: [APP] - version 1.16.x
Post by: menion on January 20, 2012, 09:08:50
Thanks Gynta for report. Texts are really weird and also error you send is more then weird :). Looks like some corrupted version on your tablet

so please try this test version. Also Joe, this version have enabled debug messages ;)
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 20, 2012, 09:36:37
maybe i'm too silly, sorry :-). i use
adb logcat *:V | grep locus
on windows and it only outputs general crap about locus gui events. nothing about maps at all.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 20, 2012, 09:40:19
forget on grep in this way ... it's some unsolved problem also for me, but in logcat is not best to search by name of application but it's only useful tu search by process ID, so find ID of locus process and search by this ...
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 20, 2012, 09:58:03
ok... here we go:

W/FileMapTypeRMap(25330): initializeMapNew(), file:/mnt/sdcard/external_sd/Maps/KMP-Alpen-DE-AUT-CH-IT-SLO.rmap
D/FileMapTypeRMap(25330): readHeader(), name:CompeGPSRasterImage
D/FileMapTypeRMap(25330): type:8, width:141049, height:55905, tileWidth:256, tileHeight:256, mapDataOffset:3314475851, paletteSize:0

thats it for this map. not very helpful i fear. how about some file reading error messages at mapDataOffset? :-)
Title: Re: [APP] - version 1.16.x
Post by: menion on January 20, 2012, 13:30:47
hmm quite interesting. No error message later? There should be any ... :)

anyway, we're now closer to place with problem, so ... next test version here viewtopic.php?f=25&t=1537&p=9551#p9551 (http://forum.asamm.cz/viewtopic.php?f=25&t=1537&p=9551#p9551)
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 20, 2012, 13:37:06
Quote from: "menion"
...so please try this test version...
"Settings"works now again. thx.
but the blurring text is still present.
strangely different in one requester (see attachment)
Title: Re: [APP] - version 1.16.x
Post by: menion on January 20, 2012, 13:56:29
when you go to settings, do you see top panel with locus icon?

and about texts ... this is really mystery for me :). On screenshots, looks like you have some shadow on texts. Also attribution on map have some shadow even I don't use any shadow in locus for basic texts. Bigger mystery is this because one version looks correctly and second not ... anyone with same issue?
Title: Re: [APP] - version 1.16.x
Post by: menion on January 20, 2012, 14:17:33
hmm, may you please try one more version? I forced locus texts to not use any shadow manually so I'm interested if this helps ... thanks gynta
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 20, 2012, 14:23:05
del me plz
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 20, 2012, 14:33:50
sure. in this moment i test  an older vers 1.14... looks fine.
but now, i will test 1.16.1.4...

...back
not all is korrekt but the "about"panel works now.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 20, 2012, 14:57:21
not all :) oki ... and where is still problem? this have to be some weird settings of GUI of your tablet. This will for sure solve ICS anyway because I do not changed skin for whole app, it's really weird that this issue occur
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 20, 2012, 15:07:40
if i'm the only one user with this problem - i will wait for the next androidupdate. np.
I can change the settings already blind ;)
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 21, 2012, 22:13:51
You're like a bloodhound. Finaly, you got it! :D
In version 1.16.2.2 there are no incorrect text representations.
and "Settings" has now white(grey) BG.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 21, 2012, 22:36:47
ah, perfect ... because this seems to cause more troubles on all 3.x androids, I'll release tomorrow or in monday one more version. So if anyone report any issue, post it as soon as possible. I'll then take some longer break with new release
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 22, 2012, 19:08:07
W/FileMapTypeRMap( 9448): initializeMapNew(), file:/mnt/sdcard/external_sd/Maps/KMP-Alpen-DE-AUT-CH-IT-SLO.rmap

D/FileMapTypeRMap( 9448): readHeader(), name:CompeGPSRasterImage

D/FileMapTypeRMap( 9448): type:8, width:141049, height:55905, tileWidth:256, tileHeight:256, mapDataOffset:3314475851, paletteSize:0

D/FileMapTypeRMap( 9448): setZoom:0, 159

D/FileMapTypeRMap( 9448): setZoom:1, 2364637996

D/FileMapTypeRMap( 9448): setZoom:2, 3078374010

D/FileMapTypeRMap( 9448): setZoom:3, 3259901994

D/FileMapTypeRMap( 9448): setZoom:4, 3302008424

D/FileMapTypeRMap( 9448): setZoom:5, 3311663300

D/FileMapTypeRMap( 9448): setZoom:6, 3313841769

D/FileMapTypeRMap( 9448): setZoom:7, 3314330748

D/FileMapTypeRMap( 9448): setZoom:8, 3314441201

D/FileMapTypeRMap( 9448): setZoom:9, 3314466990

D/FileMapTypeRMap( 9448): setZoom:10, 3314473836

W/FileMapTypeRMap( 9448): header readed

D/FileMapTypeRMap( 9448): readMapData(3314475851), pos:159

E/FileMapTypeAbstract( 9448): constructor()

E/FileMapTypeAbstract( 9448): java.io.IOException: Value too large for defined data type

E/FileMapTypeAbstract( 9448):    at org.apache.harmony.luni.platform.OSFileSystem.seek(Native Method)

E/FileMapTypeAbstract( 9448):    at dalvik.system.BlockGuard$WrappedFileSystem.seek(BlockGuard.java:210)

E/FileMapTypeAbstract( 9448):    at java.io.RandomAccessFile.seek(RandomAccessFile.java:705)

E/FileMapTypeAbstract( 9448):    at menion.android.maps.b.o.a(L:223)

E/FileMapTypeAbstract( 9448):    at menion.android.maps.b.o.a(L:107)

E/FileMapTypeAbstract( 9448):    at menion.android.maps.b.f.<init>(L:90)

E/FileMapTypeAbstract( 9448):    at menion.android.maps.b.o.<init>(L:67)

E/FileMapTypeAbstract( 9448):    at menion.android.maps.b.b.a(L:114)

E/FileMapTypeAbstract( 9448):    at menion.android.maps.b.b.c(L:427)

E/FileMapTypeAbstract( 9448):    at menion.android.locus.core.bc.doInBackground(L:1)

E/FileMapTypeAbstract( 9448):    at android.os.AsyncTask$2.call(AsyncTask.java:185)

E/FileMapTypeAbstract( 9448):    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:306)

E/FileMapTypeAbstract( 9448):    at java.util.concurrent.FutureTask.run(FutureTask.java:138)

E/FileMapTypeAbstract( 9448):    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1088)

E/FileMapTypeAbstract( 9448):    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:581)

E/FileMapTypeAbstract( 9448):    at java.lang.Thread.run(Thread.java:1019)
Title: Re: [APP] - version 1.16.x
Post by: Szczepanik on January 22, 2012, 19:44:17
Menion thank you for the continual improvements to Locus. When I exit from  Locus 1.16.2, I sometimes get taken to a blank white screen and have to press the back button again to fully exit.  :(
Quote from: "menion"
21.1.2012 - Locus 1.16.2
Cheers
Tom
Title: Re: [APP] - version 1.16.x
Post by: menion on January 22, 2012, 21:45:56
Joe,
 seems like this issue - http://code.google.com/p/android/issues/detail?id=21696 (http://code.google.com/p/android/issues/detail?id=21696) , do you have possibility to test your huge map on device above A3.x? because I don't have any RMAP bigger then 2GB to test

Szczepanik,
  you're of course welcome. If you discover exact method how to achieve this bug, I'll fix it. Anyway I think that it should be when you change in settings something that needs restart of locus (language for example). It also happen on one my phone ... damn, have to fix it
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 22, 2012, 22:07:01
Quote from: "menion"
...I don't have any RMAP bigger then 2GB...
...and nobody need it. :roll:
i read it: DE-AUT-CH-IT-SLO
Wtf - in one day have been changed hundred roads, sidewalks, paths,...
This map never can be up to date.
It is better to have several parts.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 23, 2012, 09:28:18
no honeycomb or better here to test yet... that will have to wait a bit until ics reaches the galaxy note. i remember vaguely reading something about a way around a 2gb gingerbread limit using some sort of memorymapped(?) file access, but i cant find it anymore now.

oh well, it's probably not worth bothering if it will start working automagically on ics.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 23, 2012, 16:43:16
btw... talking about debug output. i believe Locus fails to use the pressure sensor in the Galaxy Note. probably only minimal changes are necessary to support that, it cannot be much different from the nexus. Any hint on what debug output i might look for?
Title: Re: [APP] - version 1.16.x
Post by: menion on January 23, 2012, 17:27:57
hmm don't know before, memory-mapped system but I'm worried this will also not help in android. Maybe yes, but this haver really too low priority. You may add it as idea on getsatisfaction, maybe there will be a lot of people interested

about barometer. Why you think it do not work correctly just on Note? Maybe it's generic problem of Locus. So describe me please little bit your issue ...
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 23, 2012, 18:12:14
Well... I have enabled the pressure sensor but my tracks look just as rubbish as always... altitude is jumping in typical gps fashion. I cant really tell for sure obviously, since Locus doesnt give any hint whether it uses the sensor. You might want to add some field for the current pressure sensor value somewhere.
Title: Re: [APP] - version 1.16.x
Post by: menion on January 23, 2012, 19:57:23
you may simply check it by

menu > sensors > pressure-calibration

and here select "altitude" and set there some value. By pressing "Confirm" you should see computed values of calibrated pressure that will be used.
So if you set altitude 100m, Locus will take current pressure value and compute "pressure at sea level" value. This will be used for altitude compute

I think, that you can for example test pressure, if you insert altitude +1000 to your current value. Then you'll see all altitudes +1000 above real value, so you'll see if altitude is from pressure sensor or not

PS1: how should I call you? Stefan or Joeloc? - I'm little bit confused.
PS2: thanks for email: I was thinking about creating some separate screen (something like compass screen) just for pressure sensor. Something like old wall barometer :)
PS3: ah, please change once forever my email to locus(@)asamm.com
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 23, 2012, 20:30:40
ok... seems 1.16.4 uses the pressure sensor after all, at least on manual calibration.

an old-style barometer might be visually appealing and pretty. more useful would probably be a graph where you plot gps altitude against pressure sensor, ie for checking weather developments. but i'm not an expert on that, better let some meteorology guys speak :).

btw... locus still has a *serious* bug when an RMAP is completely off screen. it slows to a CRAWL even on 2x1400MHZ. 1.16.4 for example needs 5 (five!) seconds just to open the main menu right now, the whole thing is completely unusable.

everything is FINE as soon as the map is at least partially on screen.
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 24, 2012, 21:18:45
Quote from: "menion"
that's how all setting in locus looks like ... right, almost all, not all looks like this now....problem and change comes with some more complicated settings. What about these? (on screenshots) ... they're too complicated to basic system that allow android.
btw....  :roll:
Title: Re: [APP] - version 1.16.x
Post by: menion on January 25, 2012, 14:58:45
just a detail :) anyway thanks ...

joe, what about maps? RMAP problem outside of map?
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 25, 2012, 15:05:45
load your biggest rmap.
move to its top border, so that about 50% of the screen is white.
create a waypoint in the white part so that you can see/feel the slowness.
move the map around.
notice how smooth it is (by watching the waypoint) when parts of the map are still visible.
notice how slow and jumpy and sluggish it becomes when the whole map is offscreen (you move around the white part).
Title: Re: [APP] - version 1.16.x
Post by: menion on January 25, 2012, 15:27:09
ah sorry, I'll ask better :)

any progress in last version? Also please check if settings: menu > settings > map > map auto-load have impact on this. Thanks!
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 25, 2012, 16:11:09
dont know about 1.16.2... i can only use beta versions, not market versions :).

map-auto-load is turned off and 1.16.1.4 still has the problem. for example, i load a rmap of the canarian islands but move the cursor to munich/germany: locus becomes unusable instantly... even opening the main menu or selecting an item there will take 4 seconds. as long as the map screen (all white obviously) is visible, everything is more or less dead.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 26, 2012, 20:28:46
1.16.1.4... all my vector maps are gone! locus doesnt see any .map file it seems :-(
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 28, 2012, 15:44:03
hey menion

Locus Pro 1.16.3 on my SGTab.
Settings screen.
Can u plz resize the menu-lines-height?
See screenshots new vs oldstyle:
Title: Re: [APP] - version 1.16.x
Post by: menion on January 30, 2012, 07:53:57
hmm this is really stupid. Every company that create phones/tablets change GUI in their way. Left panel is generated automatically and sizes are defined by style builded in tablet. On Xoom it looks correct ...

is left panel at least scrollable? If so, then this is just a cosmetic issue ...
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 30, 2012, 10:34:06
strange. the gui looks different.
the checkboxes, the topics,...
what ever! i'm just waiting for the Androidupdate...
Title: Re: [APP] - version 1.16.x
Post by: menion on January 30, 2012, 10:41:32
yes it looks ... on Xoom is default android looks (it's 4.0.3 version but 3.2 looks same), you have GUI modified by Samsung. And seems that's modified a lot ...
Title: Re: [APP] - version 1.16.x
Post by: berkley on January 30, 2012, 11:37:58
Hey,
just telling, that menu setting looks nice on TF101 at default 3.2.1.
Cheers
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 30, 2012, 13:35:29
Might I repeat the issue that neither the latest beta nor the latest market version display any kind of vector map. I have plenty of *.map in my configured maps folders that worked flawlessly before. Does nobody else have this problem? What am I doing wrong? Thats quite a major showstopper here.
Title: Re: [APP] - version 1.16.x
Post by: tramp20 on January 30, 2012, 14:21:05
The OSM vector maps from here:
http://www.vectormaps4locus.eu/the-maps (http://www.vectormaps4locus.eu/the-maps)
display all ok.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 30, 2012, 14:26:05
not for me. i dont even see them in the list. all raster maps (rmap etc) from the same directories show up nicely.
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 30, 2012, 15:16:00
Quote from: "joeloc"
Does nobody else have this problem?
nope  :| maybe u can kick locus completely and then reinstall.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on January 30, 2012, 16:28:09
i kicked it a lot already and nothing happened :-(.

menion, i still think you should add proper error handling for your map reading stuff. whenever your directory scanner finds a file and locus refuses to add it to its list of maps (wrong projection, too big, too small, memory troubles, whatever), i want to know about it. collect the error messages in a string and show a requester afterwards.

right now it's just fishing in the dark... nobody has a clue whats going on and why some files work and some others dont.
Title: Re: [APP] - version 1.16.x
Post by: gynta on January 30, 2012, 18:23:04
Quote from: "joeloc"
i kicked it a lot already

inkl. remove all Locus dirs (ext. mapdirs...)?
u know: "uninstall" means not "remove all".
Title: Re: [APP] - version 1.16.x
Post by: dibrial on January 31, 2012, 20:36:45
I exported my overlay map (http://http://forum.asamm.cz/viewtopic.php?f=10&t=1359) to a GeoTiff and then used Compeland to export to .rmap. The map opens in Compeland, but is not shown when copied to /locus/maps/.

Please advise?

btw. the map can be found here (http://http://minus.com/msjyxOFjj)
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 01, 2012, 23:33:19
my advice is to wait for menion to give us proper error messages when scanning the map folders :-).

none of my mapsforge vector maps shows up anymore since weeks and i still dont know why.
Title: Re: [APP] - version 1.16.x
Post by: lml on February 02, 2012, 01:09:12
Quote from: "joeloc"
my advice is to wait for menion to give us proper error messages when scanning the map folders :-).

none of my mapsforge vector maps shows up anymore since weeks and i still dont know why.

Have you defined a custom map directory? I have done that and my vector maps also disapperared from Locus, but I found a workaraound.  :)

If I copy one of the map files to the Locus default directory (on my phone it is /sdcard/Locus/mapsVector) then I can see all maps in my custom map directory plus the map that is in the default directory. If I remove the copied map from the default directory I can no longer see any maps at all.

It worked for me before but something broke in one of the recent upgrades, perhaps when Locus was upgraded from version 1.15.x to 1.16.x. I don't remember in which version the setting to define custom map directories was added.

Maybe it is a bug in the code that searches for maps during startup?
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 02, 2012, 08:38:21
that worked. thanks!
Title: Re: [APP] - version 1.16.x
Post by: menion on February 02, 2012, 08:40:03
hey guys, such mistake? damn ...

EDIT: ah gotcha ... you have copied all vector maps to different directory right? Hmm it's old code that search default directory and if there's no map, it ends instead of continue on other custom directories. Fixed now, sorry  for troubles Stefan
Title: Re: [APP] - version 1.16.x
Post by: menion on February 02, 2012, 11:40:12
guys, you may check testing version if first post
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 02, 2012, 12:38:48
How's the OpenGL learning moving along? :-)
Title: Re: [APP] - version 1.16.x
Post by: menion on February 02, 2012, 12:40:01
no time for this ... later (I think I'll start at April)
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 05, 2012, 14:08:29
Hm... Where did my track name labes go? They disappeared with latest beta :(
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 05, 2012, 14:10:06
Aha... track name labels depend track icon settings now. I have track icons set to No symbols and that kills my name labels as well.
Title: Re: [APP] - version 1.16.x
Post by: menion on February 05, 2012, 14:38:19
yes, leave at least dots if you want have visible labels
Title: Re: [APP] - version 1.16.x
Post by: superscout03 on February 05, 2012, 17:25:10
I am trying to download the testing version to test it out. But it keeps saying (download unsuccessful)  is the link broken now?
Title: Re: [APP] - version 1.16.x
Post by: jusc on February 06, 2012, 08:02:35
Just tested. Download with PC works. App is installable.
Title: Re: [APP] - version 1.16.x
Post by: Sebulba2k on February 26, 2012, 11:20:18
Hi menion,

where can i find the latest 1.16.x apk-File ???
can you upload it here ?

THX.
Title: Re: [APP] - version 1.16.x
Post by: menion on February 26, 2012, 11:58:57
and why this? New version 2.0.1 is fully working now ...
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 26, 2012, 14:20:19
Getsatisfaction never worked in the last week. Website not reachable, at least not via spanish vodafone. Besides... isnt it very cumbersome to use compared to tapatalk etc? Forums rule :). Your choice of course, but a mobile app should support easy bug reporting from mobile devices imho.
Title: Re: [APP] - version 1.16.x
Post by: jusc on February 26, 2012, 15:25:12
https://getsatisfaction.com/locus (https://getsatisfaction.com/locus) just in this moment tried from german vodafone without any problems.
Title: Re: [APP] - version 1.16.x
Post by: joeloc on February 26, 2012, 19:50:10
Still doest work for me... in fact in never worked from spanish vodafone. Oh well, no satisfaction for me then :). Its a shame... we had such a nice forum here and now its more or less dead. Two places for bug reports and discussions simply do not work.
Title: Re: [APP] - version 1.16.x
Post by: menion on February 26, 2012, 20:20:46
joe, both forum will be working. Anyway you "have to" understand that for most users (and most of them are just basic users) is this forum confusing and too full of informations. I needed something clean and simple for all people. Anyway I'll still be communicating on both places in same enthusiasm, don't worry ;)
Title: Re: [APP] - version 1.16.x
Post by: Sebulba2k on March 01, 2012, 09:26:49
hi menion,

i ask for the last 1.16.x .apk-File.
I want to stay on the old Version for a while, because the new one not working stable on my Phone.
(Motorola Milestone with Android 2.2.1 CyanogenMod-6.3.6)

I using Locus for GeoCaching an the new 2.0.1 regulary crashes.
Espacially when i using "Custom guiding Sound".
Title: Re: [APP] - version 1.16.x
Post by: menion on March 02, 2012, 16:40:15
Sebulba, is crash when using "Custom guiding sound" the only one issue? May you send me log from this crash? I can send you older version on email but I think that much better will be fix current issues ...
Title: Re: [APP] - version 1.16.x
Post by: Sebulba2k on March 02, 2012, 20:08:27
hi,
i' m trying to log the crash next time i go caching. So you can look at it.
But by the while it will be nice, if you can sent me the last version of 1.16.x to sebulba2k(at)gmail.com
thx.